All Forums Database
aklopis 6 posts Joined 08/15
06 Oct 2015
"The string contains an untranslatable character" in table name

Hi.
When I tried to drop the table I got the error "The string contains an untranslatable character" The table name looks like "sth_wro->s" in Teradata Administator. I tried using BTEQ to select the table name from dbc.tables with various session charset, but it's still the same.
How can I get the real table name or just drop it?
 

 

Tags:
david.craig 73 posts Joined 05/13
06 Oct 2015

Always use the modern views to access objects in the data dictionary. These view names end with a suffix of "V", "VX", or "V_SZ". In your case, you want the TablesV view. The reason you don't want to use the compatibility DBC.Tables view is because it uses a legacy UNICODE_TO_LOCALE translation. See the Data Dicitonary reference for more details.
Use the char2hexint function to return the hex equivalent of the table name. The resulting string can be used in a Unicode Delimited Identifier (i.e., U&"") to refer to the table name independant of the client tool, or character set. See the SQL Fundamentals reference for more details.
Let me know if this helps.
-Dave

aklopis 6 posts Joined 08/15
14 Oct 2015

Thanks, Dave
I didn't try your idea, because I guessed the character and dropped the table. I'm sure I'll use it in the future.

You must sign in to leave a comment.