All Forums Database
shindeswapnali 2 posts Joined 08/13
12 Mar 2014
The Parcel Stream is Invalid

Hello experts,

I am trying to update some records in teradata table and when updates finish I am inserting some records using Ab Initio. I am using mload utility. My graph is failing with below error:

========= Error from fmwk_dwh_load_table.Inserts_multiload.Update_Table _I_nsert__macro_.tload.000 on ab8p.wload.barclays.co.uk%000 =========
ABINITIO(DB00001): Failed connecting to the database <dwsana>.
ABINITIO(DB00001):
ABINITIO(DB15038): Teradata ODBC Error
ABINITIO(DB15038): SQLCODE: -8019
ABINITIO(DB15038): SQLSTATE: HY000
ABINITIO(DB15038): MESSAGE: [Teradata][ODBC Teradata Driver][Teradata Database] The parcel stream is invalid.
ABINITIO(DB15038): Teradata ODBC Error
ABINITIO(DB15038): SQLCODE: 0
ABINITIO(DB15038): SQLSTATE: 28000
ABINITIO(DB15038): MESSAGE: [Teradata][ODBC Teradata Driver] Not enough information to log on
ABINITIO(DB00067): Current DB Environment:
ABINITIO(DB00067): ODBCINI=/wload/ab8p/home/ab8pgpdw/.odbc.ini COPERR=/opt/teradata/client/13.10/lib COPLIB=/opt/teradata/client/13.10/lib TWB_ROOT=/opt/teradata/client/13.10/tbuild NLSPATH=/opt/teradata/client/13.10/tbuild/msg/%N:/ wload/ab8p/tws/maestro/catalog/%L/%N.cat:/opt/t eradata/client/13.10/odbc_32/msg/%N LANG=en_GB TD_ICU_DATA=/opt/tdicu/lib

ABINITIO(*): Database Package Version 3-0-4-6-e11-1

ABINITIO (3.0.4.6): Mon Mar 10 22:50:38 2014
ABINITIO: Rolling back ...

This is not happening every time. Sometimes it runs and sometimes it fails. There is no fix pattern for the failure. Can anyone of you let me know possible issue with this?

Thanks,
Swapnali S.

Thanks and Regards, Swapnali S.
Raja_KT 1246 posts Joined 07/09
12 Mar 2014

Hi,
Do you update manually using Teradata and once done, you use ab initio for inserting?
One reason can be the dbc file content is changed like  db name, username,password ..
Did you test:
m_db test yourdbc_name.dbc immediately after the failure and see the timestamp change of dbc file too.

If not so,can you post some more mload log details
Cheers,
 

Raja K Thaw
My wiki: http://en.wikipedia.org/wiki/User:Kt_raj1
Street Children suffer not by their fault. We can help them if we want.

lokmac 8 posts Joined 08/09
08 Apr 2014

Hi,
I'm not sure what the reason is for that error (though I'm experiencing the same error when connecting from Informatica PowerCenter 8.6.1 on Solaris 10).
However, if you're intending to use "mload" it looks like you are not.  That error is from the Teradata ODBC driver:

[Teradata][ODBC Teradata Driver][Teradata Database]

If I find an answer to my issue I'll be sure to share it in case it's similar to yours (or if you've solved the issue yourself then please share the solution).
Thanks.
 

Win 28 posts Joined 03/13
23 Jun 2014

Hi,
I have also encountered this similar error. Sometimes, the query fails and sometimes it succeeds. I do not yet know the cause.

SPI 1 post Joined 09/12
23 Jun 2014

Hi, this is a known issue, contact the support and ask for ODBC 13.10.00.12 for the JIRA ODBC-11862.

Raja_KT 1246 posts Joined 07/09
23 Jun 2014

Maybe you can contact the support team from the vendor. For Abinitio, you can send the package to support at abinitio. You can get the email address from the console. They will analyse it and send you the root cause and fix.

Raja K Thaw
My wiki: http://en.wikipedia.org/wiki/User:Kt_raj1
Street Children suffer not by their fault. We can help them if we want.

You must sign in to leave a comment.