All Forums Database
uzovka 4 posts Joined 06/11
16 Feb 2012
SHOW MACRO/TABLE does not always return full DDL

Hi all,

in some cases when I run SHOW MACRO some_macro or SHOW TABLE some_table I do not get the full DDL, only first few lines. This happens on two separate PC's, tested with SQL Assistant and Nexus Query Chameleon. As DDL is always truncated at the same place I first  thought this is related to teradata driver (13.10.00.02 windows version - TDATA32.DLL). The only configuration setting I have found is "Maximum Response Buffer Size" (8192 by default) but increasing this value doe not have any effect.

Running this query gives me the same truncated result:

select * from dbc.tables where databasename = 'db_name' and tablename='macro_name'

Any ideas what can cause such behavior?

ulrich 816 posts Joined 09/09
16 Feb 2012

Do you connect with ODBC or .net?

In other posts it was suggested to use .net.

 

feel free to donate bitcoin:12kgAUHFUqvG2sQgaRBXFhCwyf9HXdkGud

uzovka 4 posts Joined 06/11
17 Feb 2012

.net works fine, thank you.

amaze17 2 posts Joined 01/14
02 Feb 2015

Hi ,
im still not getting the complete definition even after using Teradata.net connector in Teradata 14.1 
Please help me with some way to extract the complete macro definition.
 
Thks,
Maze

You must sign in to leave a comment.