All Forums Database
SAP 73 posts Joined 08/14
12 Oct 2014
Response Row size or Constant Row size overflow

Hi All ,
Please help me on the below mentioned error while just selecting a view
 
Executed as Single statement. Failed [9804 : HY000] Response Row size or Constant Row size overflow.
Elapsed time = 00:00:00.140
 
STATEMENT 1: Select Statement failed.
 
Thanks !!!
 

SAP
Glass 225 posts Joined 04/10
12 Oct 2014

Sap,
What tool are you using to execute your query?
Rglass

david.craig 73 posts Joined 05/13
12 Oct 2014

Have you attempted the remedy for error 9804 as described in the messages reference manual?
Remedy:
Change the SQL and/or reduce the data field sizes and/or number of fields being returned and resubmit the
request. Limit the projection list and order by clause to approximately 64k bytes of data each.

SAP 73 posts Joined 08/14
12 Oct 2014

Hi Glass ,
I am using Teradata Studio express 15 .
 
Hi David ,
If i reduce the data field sizes , it will affect my data present in the field . :( :(
 

SAP

Raja_KT 1246 posts Joined 07/09
12 Oct 2014

If you can perchance reduce your order by if it meets requirements.It can be due to character set session  too.

Raja K Thaw
My wiki: http://en.wikipedia.org/wiki/User:Kt_raj1
Street Children suffer not by their fault. We can help them if we want.

HarshaKudumula 83 posts Joined 04/09
11 Mar 2015

If you are using ODBC or .Net Driver, I think you are using session mode is set to "ANSI", so that is reason you are getting 9804 erro. why because it can't able to display the results if it crosses row size limit. i think, it is better to change the session mode to "System Default", so you can able to get the results with out 9804 error.

M.Saeed Khurram 544 posts Joined 09/12
16 Apr 2015

Hi,
I was facing the same issue in one of my queries, and I investigated and found that I used oreplace function multiple times, I removed the oreplace function and it worked without any issue. So if you are using any UDF in your query, it can be one reason of this issue.
Br,
Khurram

Khurram

abhinavtd 3 posts Joined 04/15
16 Apr 2015

From memory this error comes if  your output row size is more than 64K Bytes.
64K Bytes is a lot of data. Are you sure that you can't accomodate your result in less than that?
What data types are of the columns in the Select Clause of your SQL?

tinazmu 1 post Joined 05/11
22 Jun 2016

I know this post is quite old, but in case someone hits this problem and can't solve it by reducing the results: the same error is produced if the IN clause has too many items (or, perhaps, larger than 64K?), splitting the query to multiple identical pieces, with portions of the in-list in each and combining them with union-all resolved it.

kbhatt000 1 post Joined 09/15
03 Aug 2016

I had the same issue and I was able to resolve it by changing the charset to ascii from UTF.

You must sign in to leave a comment.