All Forums Database
10 Nov 2009
Problems with SP compilation

I have problems to compile any sp with Teradata 13 Express and VS Express 2008 sp1. Compilation of a trivial procedure

Replace procedure RETAIL.sp_T()
begin
declare job char(12);
end;

fails with *** Failure 5547 Internal Error: Can not find mt.exe

The routine exists in Windows SDK, that is installed with VS Express. Adding the directory to the path variable does not help.

When I use diagnostic spldebug on for session, I can find, beside souce c code, other 5 files in the directory C:\ProgramData\Teradata\Tdat\tdconfig\TDSPTemp with following suffixes .clist, .mds, .olist, .req, .uni. No object file was created.

The problem is the same for both Win 7 RC and Win XP sp3.

Any help would be appreciated.

hyperj 7 posts Joined 09/09
13 Nov 2009

I am afraid this is DR 135079 which may not have a 13.0 fix yet. I have made an inquiry about it. "Because of having semicolon in middle, it is not finding mt.exe file."
Could be a VS2005 issue only, not sure at this time.

hyperj 7 posts Joined 09/09
13 Nov 2009

A fix in 13.0 is on it's way. The best I can determine at this time is that the issue is specific to VS2008 and earlier versions of VS should not have the problem.

18 Nov 2009

Thank you for the reply. It would be nice to know which Ms VS / VC++ /Windows sdk work beside old VC++6 whis has compatibility problems on Windows 7. Will Teradata intend to ocasionally update the Express editions? Express 12 seems to have the same version that was published about a year ago.

ChinaGuy 41 posts Joined 09/09
18 Nov 2009

Before I took on my current role in China, I used to manage Teradata database porting programs on the Windows platform and the MS compiler question is one that I get from time to time. Generally speaking, Teradata database supports every MS compiler out there and we put people's time to make sure that our database work with both paid and free versions. Paid versions include every version of MS Visual Studio. Free versions include MS Visual Studio Express (32-bit windows) and MS Windows SDK that includes a free compiler. In the recent versions of Windows SDK, there seems to be several issues with MS either not including key compiler executables in their SDK installer or including older versions of the compiler executables. If you run into these issues, you can copy over the correct executable from the paid versions of MS visual studio. The compilers for both paid and free versions are essentially the same.

26 Dec 2009

Can you reply into which folder the mt.exe should be inserted? I've put it where the bteq.exe is located, but it is still carping it cannot be found.

ChinaGuy 41 posts Joined 09/09
26 Dec 2009

it should be put under the bin directory of where your Microsoft SDK or visual studio is installed on the database server. e.g. c:\program files\Microsoft (product) \ version \ bin

gmiller261 1 post Joined 01/10
29 Jan 2010

I get the same error/dialog box when I try and add a stored procedure using Teradata SQL Assistant. V13, local Teradata Express.

Any fix out there?

FAQ 2 posts Joined 05/09
09 Mar 2010

I have 2 Visual Studio versions installed on my system VS 6 and VS 2008; I am getting the same error, how can I configure Teradata to use VS 6 for compiling Stored Procedures?

14 Jul 2011

Hi,

I am getting same error can someone specify which compiler is compatible with Teradata 13 version. windows xp service pack 3 and microsoft vc++ 2008 compiler. prompt reply is Appreciated.

thnx

bc185039 1 post Joined 10/11
15 Feb 2012

Hi,

Am facing the same error with TD Express 13.0.0.12 running on windows xp. I find same error with microsoft vc++ 2005, microsoft vc++ 2008.

Any inputs on resolving this issue is please?

Thanks

Kalyan

 

 

You must sign in to leave a comment.