All Forums Database
ricky_ru 16 posts Joined 11/12
19 Feb 2014
ODBC client on windows

I am going to be crazy by installing the ODBC driver on windows.
1) I downloaded the version from here: odbc-driver/windows
2) Installed to follow the right order. icu->gss->odbc
3) At the end of the software, I am able to have the chance to launch the odbc onfig ui and readme. And I could config a odbc DSN.
4) But the problem is that when I want to add new dsn, there is no teradata item in the list to be selected. And I could not remove/config the previous one in step 3 as there is no driver found/not registered issue shown.
5) It looks to me that in step 3, the driver information is in memory. But it could not write to the system register or other files.

I tried to use admin to install and modify the register table permission. But still got the problem. Also, it does not  have the port number field and no test button.

Do you have any idea?


Thanks, RR
Adeel Chaudhry 773 posts Joined 04/08
19 Feb 2014

Is the DSN created? Is it a 64-bit Windows? Which ODBC are you checking .... ODBC 64-bit or ODBC 32-bit? Which tool are you trying to connect with .... Teradata Admin? SQL Assistant?

-- If you are stuck at something .... consider it an opportunity to think anew.

jinli 10 posts Joined 11/12
19 Feb 2014

some td-gui tools may still not work with 64bit odbc driver even though your win-env might be 64bit already, and in that case you need 32bit odbc driver to be installed and then use 32bit odbc admin to configure. usually 32bit odbc admin sits in C:\Windows\SysWOW64\odbcad32.exe.

M.Saeed Khurram 544 posts Joined 09/12
20 Feb 2014

I think your machine is 64 bit, please confirm, if you machine is 64 bit then you will not able to see any drivers in 64 bit ODBC, rather you should use 32 bit odbc. Go to the Start -> All programs -> in search write ODBS, and choose 32 bit ODBC. 


Adeel Chaudhry 773 posts Joined 04/08
20 Feb 2014

The string 'i386' in your version suggests you installed 32 bit driver.
Hence it will only be visible in ODBC 32Bit and wont be available in ODBC 64Bit (which opens up by default on 64bit Windows). It should resolve your issue.

-- If you are stuck at something .... consider it an opportunity to think anew.

You must sign in to leave a comment.