All Forums Database
shyguy 9 posts Joined 08/09
24 Sep 2009
Invalid session mode for procedure execution

Am facing this error- 'Invalid session mode for procedure execution' while calling a proc through Java/JDBC. I am guessing that this error has something to do with the db layer.

Solution/Fix?

Tags:
dnoeth 4628 posts Joined 11/04
24 Sep 2009

You have to set the session mode to the same mode used when the SP has been created.
You get that info when you submit a "help procedure xxx attributes;"

Then set it in the connection URL using TMODE.

Dieter

Dieter

shyguy 9 posts Joined 08/09
25 Sep 2009

Thanks Dieter.

17 Apr 2012

Hi Dieter, 

I am having the same trouble. I am trying to call it from SAS. It says 'Invalid Session Mode for procedure execution' Any suggestions? I did some research and found out i should have executed the macro using ANSI session mode is that true? 

 

Thanks for your time. 

gunarvingren 1 post Joined 01/14
04 Feb 2014

go to ODBC configuration on windows control panel.
go to teradata configuration and set the option "Session Character Set" to UTF-8. Then click the button "Options" and set the option "Session Mode:" to ANSI.
it worked for me.

Adeel Chaudhry 773 posts Joined 04/08
05 Feb 2014

Yes, it will work with both solutions above.

-- If you are stuck at something .... consider it an opportunity to think anew.

janthony 9 posts Joined 02/10
27 Aug 2015

Hello all .. Any idea how to set this it SQL assistant 
Getting same error : CALL Failed. 5510:  Invalid session mode for procedure execution. 

help   procedure XXX  attributes

 

transaction-semantics  Platform character_set charterdatatype collation 

 

ANSI                               LINUX     UTF8               LATIN                 ASCII

 

 

Fred 1096 posts Joined 08/04
27 Aug 2015

If you are using .NET Provider (recommended) then in the connection dialog just click the "Advanced" tab and select ANSI from the Session Mode drop-down.  If you are using ODBC, then you will need to use the ODBC Data Source Administrator to configure this in the DSN Options.

janthony 9 posts Joined 02/10
28 Aug 2015

Thanks Fred , I was able to change it in below option and it worked  
ODBC ADministrator --> Configure --> Options --> Session Mode 

You must sign in to leave a comment.