All Forums Database
ncullen 3 posts Joined 05/09
30 Jul 2009
Import Problem - Date field

Trying to import a tab delimited file. Made sure my dates in the file at mm/dd/yyyy but I'm still getting the error. Created the field as type Date.Any insight?

Ansh 49 posts Joined 10/08
31 Jul 2009

Hi Ncullen,Make sure all the date field in the import file is in the format 'yyyy-mm-dd' and then try importing.I hope it works..

dnoeth 4628 posts Joined 11/04
31 Jul 2009

How do you try to import it?BTEQ/FastLoad/MLoad/TPump/SQL Assistant?Instead of changing the format in your input file you might simply add a FORMAT in the INSERT.Dieter

Dieter

ANIMESH.DUTTA 35 posts Joined 05/09
03 Aug 2009

Through Fastload/Multiload/Queryman - you can able to import any format of date.Just specify the format in the layout in case of loader utilities - or through queryman just change the date format in Options....

Animesh Dutta
Teradata Certified Master

yamu_kala 2 posts Joined 02/12
08 Feb 2012

Hi,

I'm trying to import excel file in teradata which contains date field.

It is showing error as wrong number of values in import file.

And also want to know how to add a format in insert query.

thanks in advance

ulrich 816 posts Joined 09/09
08 Feb 2012

Which tool do you use?

feel free to donate bitcoin:12kgAUHFUqvG2sQgaRBXFhCwyf9HXdkGud

13 Feb 2012

Hi yamu

If ur using queryman to import,its better to copy the content from excel into a notepad/textpad and try.set delimiter optinon to {TAB} for import in queryman..Even i got the same error.wen i tried using notepad it was fine.

yamu_kala 2 posts Joined 02/12
14 Feb 2012

Hi,

I use SQL assistant 12.0.

I tried to import notepad file. It  is working fine. Thanks.

but while importing excel file how to add a format in insert query for date field.

TD_Raj 50 posts Joined 05/10
16 Feb 2012

Hi

Make sure that the format of Date column in Target is same as the one in file you are using for Import.

You must sign in to leave a comment.