All Forums Database
addsmiles 13 posts Joined 01/12
05 Jan 2016
FASTLOAD - Record too long by n bytes

Facing the following issue with FASTLOAD:
RECORD is too long by n byte(s)
My process creates an extract from DB2 by executing a SQL through DB2 utility,  and loads the extract to a Teradata table using FASTLOAD. The process worked great in test environments, but failed with the above error when loading a file from DB2 prod environment. Table definitions are exactly the same across environments. The load file length, file layout is also the same. I have also taken care of DB2 null indicators for nullable columns. 
I am going through the manuals and researching this issue, but so far no luck.
Appreciate any inputs on the same.
 
Regards,
PT
 

Tags:
addsmiles 13 posts Joined 01/12
05 Jan 2016

Nulls in a VARCHAR column in the extract file was the culprit. Found a workaround by treating it as a CHAR by ignoring the length byte, and then using NULLIFF='00000....XC'.
Another option would have been to handle the same in the extract SQL, however, that was beyond our jurisdiction :-).
Not pretty, but worked for the time being.
The question still remains how to handle NULLs in VARCHAR column during FASTLOAD?

 

You must sign in to leave a comment.