All Forums Database
28 Oct 2014
Errormessage: The file "errmsg.cat" cannot be opened. Fastload Teradata 14.10

Hi ,
We are doing the Teradata upgrade and facing  issue in Teradata connectivity Teradata.
New Teradata Version : 14.10
Teradata Previous Version before Upgrade: 13.10
Issue: We are facing following issue while running Fastload using informatica
The file "errmsg.cat" cannot be opened.
There may be problems with your installation.
**** 14:51:22 CLI Error -1:
**** 14:51:22 Fatal error from CLI. Program exiting!
**** 14:51:22 Warning: FastLoad Interrupted
     ====================================================== =============
     =                                                                 =
     =          Exiting                                                =
     =                                                                 =
     ====================================================== =============
 
**** 14:51:22 Total processor time used = '0 Seconds'
     .        Start : Tue Oct 28 14:51:22 2014
     .        End   : Tue Oct 28 14:51:22 2014
     .        Highest return code encountered = '12'.
**** 14:51:22 FDL4818 FastLoad Terminated
 
Tried solutions:
We have tried the solution mentioned in the following forum:
http://forums.teradata.com/forum/database/error- message-with-tpt-fastload-could-not-find-message- catalog-opermsgs-cat
i)                    export NLSPATH=/opt/teradata/client/14.10/tbuild/msg64/ opermsgs.cat;

  1. Also we installed the Teradata ODBC version 15 and still no luck.
Regards Chanchal Preet Singh
ulrich 816 posts Joined 09/09
28 Oct 2014

Are you sure that CLI & fastload are both on 14.10?
Is BTEQ starting? Is it showing 14.10?

feel free to donate bitcoin:12kgAUHFUqvG2sQgaRBXFhCwyf9HXdkGud

28 Oct 2014

Hi  Ulrich,
Fastload version is 

     ===================================================================

     =                                                                 =

     =          FASTLOAD UTILITY     VERSION 14.10.00.04               =

     =          PLATFORM LINUX                                         =

     =                                                                 =

 

And bteq version is 

 

 Teradata BTEQ 14.10.00.03 for LINUX. PID: 3504

 

 Copyright 1984-2013, Teradata Corporation. ALL RIGHTS RESERVED.

 Enter your logon or BTEQ command:

 

The cli package installed is  cliv2-14.10.00.07-1

 

My fastload run successfully if I directly run it from linux server , but face the above issue when I try to call it from Informatica.
Regards
Chanchal Preet Singh

Regards
Chanchal Preet Singh

ulrich 816 posts Joined 09/09
28 Oct 2014

Hi,
so installation seems to correct. But can't help you any further as I don't have access to Informatica currently.
Is it possible that this is pointing to a old version?
Ulrich

feel free to donate bitcoin:12kgAUHFUqvG2sQgaRBXFhCwyf9HXdkGud

MarkVYoung 12 posts Joined 03/12
05 Jul 2015

Not sure if anyone ever saw a fix for this issue, but I encountered the same issue when upgrading TTU 13.10 to 14.00, and 14.10 and 15.00. For me, i was able to use BTEQ from the commanf line only after logging off and back on, as the NLSPATH variable is now setup in the /etc/profile, so I assume this only gets update when you log onto LINUX. 

You must sign in to leave a comment.