All Forums Database
tdgi 31 posts Joined 02/08
06 Jan 2011

Hi all!
On my Windows demo, I'm getting the following error in bteq:


After this message gets displayed, bteq ignores my further typing (except Ctrl-C). Furthermore, I can't log in via SQL Assistant, either. I'm sure the fast way to fix this would be to reinstall, but for the sake of learning something, how would I go about getting this working again? I should mention, vprocmanager shows everything online...

Thanks in advance!

tdgi 31 posts Joined 02/08
07 Jan 2011

As an update, if I leave bteq connected for a while, I'll get the same message repeated every hour or so, like it's trying to do something. Here is the output from vprocmanager status:

SYSTEM NAME: localhost 11/01/07 04:32:04


Vproc Rel. Node Can Crash Vproc Config Config Cluster/ Host VSS
Number Vproc# ID Move Count State Status Type Host No. Type Vproc
------ ------ ------ ----- ----- ------- -------- ------ -------- ----- -----
0* 1 1-01 Yes 0 ONLINE Online AMP 0 On 10238
1 2 1-01 Yes 0 ONLINE Online AMP 0 On 10237
8192 4 1-01 No 0 ONLINE N/A GTW 1 COP N/A
10237 5 1-01 Yes 0 ONLINE N/A VSS 0 N/A N/A
10238 6 1-01 Yes 0 ONLINE N/A VSS 0 N/A N/A
16383 3 1-01 Yes 0 ONLINE Online PE 1 COP N/A

* DBS Control AMP

DBS State: Logons are enabled - The system is quiescent

DBS RestartKind: COLD


Node Node Clique Memory
ID State Number CPUs (MB) CHANs LANs AMPs Node Name
------- ------- ------ ---- ------ ----- ---- ---- ---------------------------
1-01 ONLINE 0 2 2047 0 1 2 pdetnt01



Enter a command, HELP or QUIT:

Has anyone here seen the error before? I can't find it documented in any of the Teradata PDF's in the documentation package.
Another post somewhere on the internet suggested that this might be a problem with the gateway vproc, but the "Teradata GTW Reserve Port" service is running, and vprocmanager shows it as online. Is there anything else to check? What would be done if this were to happen on a "real" Teradata system?

Thanks much!!

dnoeth 4628 posts Joined 11/04
07 Jan 2011

How does your logon-string look like?

Seems to be a name resolution problem.
Try .logon



tdgi 31 posts Joined 02/08
07 Jan 2011

I should mention, the Teradata demo software is running on a VM elsewhere, and I have just the client bits installed. Here's the relevant line from my laptop's hosts file: corpdatacop1 corpdata

The same entry is in the hosts file on the VM running Teradata.
I invoke bteq as follows:


Teradata BTEQ for WIN32.
Copyright 1984-2009, Teradata Corporation. ALL RIGHTS RESERVED.
Enter your logon or BTEQ command:
.logon corpdata/dbc

.logon corpdata/dbc

It'll then just hang there, printing the above message about once per hour, until I kill bteq by pressing Ctrl-C three times in a row.


Aha! I didn't believe you at first that it was a name resolution issue, until I put in a bogus entry into the hosts file with an un-pingable IP, and I got the same error! Forgive my disbelief! Try this:

hosts: test testcop1

.logon test/dbc
password: dbc


So you're right. Something's wrong network-wise. But how do I track it down? The host running the Teradata demo really is, and I can ping it fine from the laptop. Attempting a .logon like you suggested, using the results in the same error. Unfortunately, I don't have bteq installed on the VM. Would a real-world Teradata server have bteq installed locally?


dnoeth 4628 posts Joined 11/04
07 Jan 2011

Is the address of the host running VMWare or the Teradata VM?

The easiest solution is to set the VM network mode to "Bridged", then it's visible in the network like a real server.



Jim Chapman 449 posts Joined 09/04
07 Jan 2011

If your Teradata VM is running in NAT mode, it is sharing the host machine's IP address, so you will need to configure port forwarding on the host machine. Port 1025 should be set to forward to the Teradata VM.

Alternatively, change the VM network mode to bridged. Then the VM will have its own IP address. You can use the SUSE administration GUI (called YaST) to configure the guest system's network interface to acquire an IP address dynamically via DHCP or to use a static IP address.

Jim Chapman 449 posts Joined 09/04
07 Jan 2011

Are you sure bteq is not installed on your VM? I believe the Teradata Express Edition for VMWare comes with a full suite of client tools. They should be in the /usr/bin directory.

tdgi 31 posts Joined 02/08
07 Jan 2011

Thanks for the responses!
Yes, is the VM running Teradata demo. This is the Windows version, running on Server 2003 in a VMware ESXi VM on a physically separate host.

Teradata Express for Windows doesn't automatically install the client tools, unless you tell it to. I opted not to on the server VM, since I wasn't sure what it'd look like out in the real-world. I'll install it locally if that's typically done on production boxes.

So port 1025 should be open on the VM running Teradata Express?

Thanks again!!

dnoeth 4628 posts Joined 11/04
09 Jan 2011

You need Bridged Mode or NAT-forwarding to work with any VM on a bare metal VM server, so this should be easy to enable (I don't know how to forward a port on ESXi as i run VMWare Fusion on a Mac and switch to Bridged if i need access from the outer world).

In Bridged mode you need to use the VM ip-address for logon, in NAT you have to use the ESXi address.
Port 1025 is for the DBMS only, there are some other ports for TD Manager etc.)

You don't install the full client on a production server, no GUI tools, but at least the load utilities (i'm not shure if BTEQ is already installed as part of the DBMS).



tdgi 31 posts Joined 02/08
10 Jan 2011

Hi there!
VMware ESXi is always "bridged" in that every VM gets it's own IP. A quick portscan shows that port 1025 is not open on the target machine, though port 1026 is. Is there a particular process on the Teradata Express server that should is responsible for opening this port? Can it be started manually or it's status checked on or something?

Again, many thanks for your help!!

tdgi 31 posts Joined 02/08
10 Jan 2011

Ha! Fixed it.
Found an event in the Application Event Log that had the following line amongst tons of other data:

The TDGSSCONFIG GDO could not be read.

So I rewrote the tdgssconfig gdo as follows:

cd D:\Program Files\Teradata\Tdat\LTDGSS\etc
tdgssconfig TdgssLibraryConfigFile.xml TdgssUserConfigFile.xml

and restarted the tpa, and voila... works like a charm!

Thanks for bearing with me!

golfingnumty 1 post Joined 04/12
04 Nov 2013

I had the same error logging into a Linux VM from windows - assuming pdestate gives RUN/STARTED
the solution restart the service by issuing
/etc/init.d/tpa stop
/etc/init.d/tpa start
check the ip address has not changed using ifconfig

x25 3 posts Joined 07/15
08 Jul 2015

I have the same issue now and am trying to start the service using /etc/init.d/apt start " and it's not working it's keeping loading forever.
even when i check status of the teradat service it is saying "DOWN/HARDSTOP" can you help plz .


You must sign in to leave a comment.