All Forums

Covers all topics related to Teradata database connectivity, including the use of client technologies such JDBC, ODBC, .NET Provider etc. For articles, blogs and more, see the Connectivity section of this site.

You must login to post to the forums.
Functions doesn't work with the ODBC connection Topic by Laura 19 Oct 2015 functions

Hello everyone,
I have lately install an ODBC connection on a new server that we have set up.
 
I connect to the database through Qlikview (a datavisualisation tool), it works well except when I want to use a teradata function.
 
For example:

494 views
3 replies, 4 years ago
Records lost while using TPUMP with MQ Topic by chitre.raunak 19 Oct 2015

Hi,
I have a TPUMP process that reads from MQ using the below parameters:

0006 .BEGIN LOAD

         ERRLIMIT 5000

         ERRORTABLE xyz

         CHECKPOINT 5

         SESSIONS 60

         TENACITY 1

         latency 0 notimerprocess

         SERIALIZE ON

         PACK 60;

 

318 views
0 replies
ODBC driver decimal culture format issue Topic by toadrw 16 Oct 2015 odbc, decimal formatting, localization

Hello:

576 views
1 reply, 4 years ago
JDBC connection timeout Topic by ecarr6 13 Oct 2015

The error message is attached below.  The main issue is that I have existing code that's working locally (surprise!) but when deployed to a different machine, I'm getting these connection timeouts.  Ping is good from the same client, but I acknowledge that firewall settings may be an issue, still.  Does anyone here have any thoughts about what may be at issue?

1027 views
1 reply, 4 years ago
Error while connecting to Teradata Topic by dtky 14 Oct 2015

When i am trying to connect to Teradata database, an error is popped up saying:
ODBC Error: Socket 60 error, No response received.
 

303 views
0 replies
Not able to connect to teradata remotely using perl DBI(DBD::TERADATA) Topic by chethanr07 21 Sep 2015

Hi All,
I'm trying to connect to teradatavm  remotely from rhel  using my perl script with DBD::Teradata driver with connect method. When i run my script on same Teradata machine its logging , but remote connectivity is not happening. I have searched in all posts and couldn't get any info.

600 views
1 reply, 4 years ago
first time ...to install JDBC Driver 15.10 Topic by perezco 05 Oct 2015 jdbc driver

 
It is  the first time that I am trying to install JDBC Driver 15.10... How to setup the correct path installation of these drivers (  terajdbc4.jar     ,   tdgssconfig.jar  ) in a WIn7 (64bit)
 
I don't have the option to access what it is said in the followinf link 

1642 views
8 replies, 4 years ago
Wrong result set when iterating through a TYPE_SCROLL_INSENSITIVE jdbc TDResultSet Topic by simon82 02 Oct 2015

I'm querying a large table with 99 columns of different types and expect to get a resultset of 3000 records. If I use a TYPE_SCROLL_INSENSITIVE ResultSet and iterate through it calling the next() method inside a while loop, It seems that after the second fetch to the database, the result set gets corrupted.

438 views
2 replies, 4 years ago
Problem with starting teradata 13.0 service control Topic by yaragalaramesh 19 Jun 2012 i need immediate solution please

 

 

   Hi,

 

    I installed Teradata 13.0 express edition after completion of installation for few days it is working good.

4899 views
2 replies, 4 years ago
Connecting to TD15 from Visual Basic Topic by mikedingwall 29 Sep 2015

I have an Excel tool that I use that connects to Teradata and brings back database information to the spreadsheet. This has been working just fine with the following connection string:-
' Create the Connection object
    Set Conn = New ADODB.Connection

767 views
3 replies, 4 years ago
Teradata with SSIS Topic by thiru.senthil 08 Sep 2008

Hi, I am a SSIS ETL guy and i need to extract data from Terada database, it is an new project recently i got assigned. Please give me some check list how can connect teradata and what are steps i should follow before going to develop SSIS Packages.Thanks....

22846 views
8 replies, 4 years ago
Using SQL Assistant to connect to MS Access database Topic by yvonnewatkins 30 Sep 2015 #connectionstring, #odbc #microsoft

I'm interested in using SQL Assistant to connect to two different databsaes.
My steps are as follows:
1) Using the connect icon => Connect to Teradata
2)  run Teradata SQL
2) Using the disconnect icon => Disconnect from Teradata
3) Using the connect icon => Connect to MS Access database
4) run Access sql.

695 views
0 replies
Connecting MS Access to Teradata to view BLOB Topic by kinselbd 29 Sep 2015 ms access, teradata, blob

I'm attempting to connect MS Accses to a Teradata table with the intention of viewing an object in a BLOB field I have stored there. 
I'm connecting Access to Teradata through a System DSN connction using Teradata driver 15.10.00.00.
My method was to link the table in Access to Teradata through this connection.

817 views
1 reply, 4 years ago
ExceptionInInitializerError while connecting to Teradata through JDBC Driver Topic by haranrk 24 Sep 2015 jdbc, hadoop

Hi,
I am trying to read data from Teradata DB in a MapReduce job using the JDBC Driver. I get the following exception/stack trace:
 
Provided connection string: jdbc:teradata://teradata/database=dbname
 

java.lang.ExceptionInInitializerError: null

at com.teradata.jdbc.jdbc.GenericTeraEncrypt.getTDgssVersion(GenericTeraEncrypt.java:640) ~[na:na]

591 views
1 reply, 4 years ago
Connecting into Teradata Database from IBMi AS400 Topic by Allan_Arce 23 Sep 2015

Has anybody ever done connecting into Teradata Database and accessing it from IBMi AS400 ( using programming language RPGLE ).
I need help, guidance.
Thanks.

492 views
2 replies, 4 years ago
Connectng from a 15.00 Client to a 15.10 Database Topic by dhorne 14 Sep 2015 client-server, version, compatibility

Hi
In order to solve a database issue, Teradat will be upgraded to 15.10 from 15.00
Can we continue to use our 15.00 to connect (i.e. is it offically supported?)
Thanks
 

483 views
1 reply, 4 years ago
tdxodbc64 vs STATE=28000 Topic by giotac 14 Sep 2015

Hello,
Trying to use ODBC 15.10 on RHL I'm getting the error :
useridX@nomemacchina ~ $ tdxodbc64  -t

Enter Data Source Name: TDDSN
Enter UserID: userid
Enter Password:

Connecting with SQLConnect(DSN=TDDSN,UID=userid,PWD=*)...

adhoc: (SQL Diagnostics) STATE=28000, CODE=0, MSG=[Teradata][ODBC Teradata Driver] Not enough information to log on

647 views
0 replies
Comparing sample data in Teradata and Netezza Topic by Rahulraj1981 06 Sep 2015

Hi All,
I have a requirement to compare sample Teardata records from one table with another table in netezza. The process which I am following currently is :
- using SQL assistant export around 500 records from Teardata table in an excel
- similarly,export 500 records from netezza(using the key records from Teradata sample in query)

538 views
1 reply, 4 years ago
Installing Teradata ODBC Driver in CYGWIN Topic by mpand 18 Aug 2015 linux, python, odbc, CYGWIN

Hi,

Can anyone share instructions to install teradata ODBC driver in cygwin enviroment.

I am trying to install and tryout Teradata for Python Module  and getting the following error.

I believe this is because of missing ODBC. 

 

1532 views
2 replies, 4 years ago
Cannot install Teradata to my Windows 7 Home Premium laptop Topic by thomasteam 11 Sep 2015

Hi,
I've been attempting to install Teradata Tools and Utilities 15.00.00.00 for about a week now but to no avail. I've received advice from Teradata recommending getting Teradata Express (runs on VMware Player) plus Teradata Studio. I was advised that essentially all I need is a Winzip utility and the VMware player to successfully set up the database.

501 views
0 replies
Catalog Error Topic by jgirish 15 Oct 2008

I am getting the following error when trying to connect to Teradata from UNIX (Sun OS). This connection was working couple of weeks back and stopped working after the server crashed due to user libraries were deleted (do not know how). I am trying to connect using ODBC entry and below is how my ODBC is setup. ---------------------------[tdp1_ip]Driver=/usr/odbc/drivers/tdata.soDescription=Dev TeradataDBCName=10.206.68.19DateFormat=AAASessionMode=ANSIDefaultDatabase=UserName=Password=---------------------------I am using to test my odbc connection. Below is the error message: -----------------------------------./demoodbc DataDirect Technologies, Inc. ODBC Sample Application../demoodbc: will connect to data source 'tdp1_ip' as user 'user1/passwd1'.SQLConnect: Failed...SQLSTATE = S1000NATIVE ERROR = 0MSG = [NCR][ODBC Teradata Driver] Unable to get catalog string.SQLSTATE = 28000NATIVE ERROR = 0MSG = [NCR][ODBC Teradata Driver] Unable to get catalog string.SQLConnect: Retrying Connect.SQLConnect: Failed...SQLSTATE = S1000NATIVE ERROR = 0MSG = [NCR][ODBC Teradata Driver] Unable to get catalog string.SQLSTATE = 28000NATIVE ERROR = 0MSG = [NCR][ODBC Teradata Driver] Unable to get catalog string.SQLConnect: Retrying Connect.SQLConnect: Failed...SQLSTATE = S1000NATIVE ERROR = 0MSG = [NCR][ODBC Teradata Driver] Unable to get catalog string.SQLSTATE = 28000NATIVE ERROR = 0MSG = [NCR][ODBC Teradata Driver] Unable to get catalog string.SQLConnect: Retrying Connect.No connection could be established. ----------------------------------------Any help on this is greatly appreciated. Thanks,

31316 views
6 replies, 4 years ago
Login Failure for connection to severner name through SQL developer .. Topic by developer9 01 Sep 2015 teradata jdbc driver, SQLState 08S01

Hi All,
I tried connecting through SQL developer for TERADATA db ..I am having following error message when making a new connection
 
"Status :Failure-Test Failed :[Teradata JDBC Driver][TeraJDBC 15:00:00:28][Error 1000] [SQL State 08S01] Login failure to connection to servername timestamp socket.org"
I added the TERADATA plugin as mentioned in the manuals.
 

1132 views
3 replies, 4 years ago
Retrieving TimeZone from TimeStamp Topic by karteeek.majety 09 Sep 2015

I am using Teradata JDBC Driver (15.10.00.05).
I have created a column for a table with data type TIMESTAMP WITH TIME ZONE ( It has the time with HH:MM:SS(upto 6 digits) + Timezone
When I fetch the resulset through JDBC I am missing the precision of seconds and also the timezone.

475 views
1 reply, 4 years ago
Teradata ODBC driver on MAC Topic by seabull 09 Sep 2015 odbc, mac, #Connectivity

After installing ODBC driver 15.10 (tried 15.00 too) on a MAC, I tried to connect to a Teradata server and got the following error.
u'[28000] [Teradata][ODBC Teradata Driver][Teradata Database] The UserId, Password or Account is invalid. '
I've tried a few approaches but none of them could connect. Would appreciate it if someone could help ...

845 views
0 replies
Result sets question on Dot Net provider Topic by jobbazar 08 Sep 2015 Dot Net provider, vb.net

I am getting a around 200/500 lines of query results that is DDLs etc returned from my dot net query.  It works on SQL assistant okay. When I send it using the below query I only get the first DDL and not other DDLs.
Any idea, if this is a limitation or any setting that I need to take a look?
Here is my code:
 

545 views
2 replies, 4 years ago

Pages