All Forums

Covers all topics related to Teradata database connectivity, including the use of client technologies such JDBC, ODBC, .NET Provider etc. For articles, blogs and more, see the Connectivity section of this site.

You must login to post to the forums.
how to provide password encryptions in JDBC connections Topic by aagrawal 16 Dec 2015

Hi,
   we have a requiremnt to enable auto connections for a JAVA application. we are using TD JDBC for connectivity. we understand SSO and TDWALLET isn't supported for this route of Teradata conenctions. we don't want to embed plain text passwords in JDBC connection strings. can you please suggest some alternate method to incoporate password encrytions in this scenario?
Regards

212 views
3 replies, 4 years ago
Session doesn't finish after connection closing in .Net application Topic by teradatauser2 16 Dec 2015 .net

Hi,
I am developing an application in .Net and using .Net provider for TD. I have the code as below. I am selecting the session no, setting a queryband and running a query and setting the query band off. Few of the values are coming from my windows form textboxes. This code runs at the click of a button on my form.

184 views
2 replies, 4 years ago
116 views
1 reply, 4 years ago
Info: App-V 4.6 bug that hits .Net Data Provider for Teradata 15.10 (and maybe other versions) Topic by evasive 14 Dec 2015 appv hklm bug

If you have something that puts user-related stuff (such as a path to LOCALAPPDATA) in a registry value under HKLM, this will break your sequence. This bug is reported here:
http://packageology.com/2013/04/app-v-v4-6-virtual-registry-bug/
Temp AppData Folder
Temp Folder
have exactly that, references to LOCALAPPDATA folders in them.
 

69 views
0 replies
Connecting Python to Teradata over ODBC Topic by Mikec 16 Sep 2009 odbc, python

Has anyone ever connected a Python based script to Teradata using the ODBC driver on Linux? We have a Sales Consultant trying to work with a prospect and getting seg faults while using the ODBC driver.
ODBC connect string for Teradata Express 12.0:
DRIVER={Teradata};DBCNAME=localhost;UID=dbc;PWD=dbc;QUIETMODE=YES;

33458 views
17 replies, 4 years ago
Cannot find terasso library with MSAccess2013 Topic by mikesicz 03 Dec 2015 terasso

I get "cannot find terrasso library" when connecting to TD via ODBC driver version 15.10 (and 15.4; worked in past with version 13) using MSAccess2013.  I do get the connection dialog and after clicking connect, I get "not enough information to log on (#0)".  

222 views
2 replies, 4 years ago
Bug in ODBC driver 15.10 Topic by d.heche 10 Dec 2015 bug, odbc, 15.10

When issueing the following statement

select case when (1 = 0) then 1 else 0 end;

in Teradata Studio 15.00.02 using ODBC Driver Version 15.10 I receive the following weird message:

519 views
3 replies, 4 years ago
305 NOREQUEST Specified request does not exist. Topic by nagendratrpth 14 Jul 2015 errorcode, connection

Hi,
Getting "305 NOREQUEST Specified request does not exist." Error while creating Volatile table through SAS connection string.
What could be the issue ?
Thanks in Advance.

691 views
1 reply, 4 years ago
.Net Provider DateTime-Timestamp Data Type Topic by epperlyw 21 Nov 2015 timestamp, datetime, .net provider, .net, teradata

I need to query a teradata table by referencing a column that is of type Timestamp(6). I'm not successful at getting the right format so far. What do I need to set the Size, Precision, and Scale values to for this to work. (By size, precision, and scale I mean these parameter values in Visual Studio's Dataset Editor)

447 views
1 reply, 4 years ago
Wierd non-text error message when trying to connect via pyodbc Topic by hd_pp 13 Nov 2014

My code:

import pyodbc
td_connstr = "DRIVER={Teradata};DBCNAME=%s;UID=%s;PWD=%s;DATABASE=%s;QUIETMODE=YES;" % (my_credentials)
pyodbc.pooling = False
td_conn = pyodbc.connect(td_connstr)

I get an error message:
 File "<stdin>", line 1, in <module>

pyodbc.Error: ('632', '[632] 523 630 (0) (SQLDriverConnect)')

 

1149 views
1 reply, 4 years ago
Teradata ODBC Driver for Linux does not work with Mono Topic by etrosce 27 Nov 2015 Mono, odbc, DataDirect, unicode, utf16, unix, linux

I've been playing with Teradata ODBC Driver for Linux x64 version 15.10. I have installed it and successfully able to connect via tdxodbc64 tool. But unfortunatelly, I wasn't able to connect via a very simple Mono application (Mono runtime 3.12.1).

450 views
0 replies
Connecting Business Objects to Teradata Topic by dazzdadawg 27 Aug 2014 #BusinessObjects #JDBC #Connectivity #Universe

Hi
 
I am running windows 7 on a 64bit machine and I want to connect to Teradata using SAP Business Objects. My first step is to create a JDBC connection but I am failling to see the drivers on the System DSN. I have downloaded both .jar files and I am confused on what to do next. I need to configure a JDBC connection but I dont have a clue on what to do.

1995 views
4 replies, 4 years ago
Teradata Hadoop Connector (HDP 1.3.3) - Schema definition is invalid Topic by tanzir 01 Sep 2014 teradata, teradata hadoop connectors, hortonworks data platform, sqoop

Hello everyone,

1147 views
1 reply, 4 years ago
Super fast way to IMPORT using Dot Net Topic by cellurl 19 Nov 2015 import

I read about a super fast way to IMPORT using Dot Net.

 

http://bit.do/tera14

 

Q: Will this be incorporated into Teradata SQL Assistant?

 

 

Thanks for any leads. I really appreciate it!

Jim

169 views
0 replies
load SAS dataset into Teradata Volatile table Topic by v_gabrielli 09 May 2012

I have several SAS tables that require to be copied over to Teradata platform V13.

I usually use the Fastload option and works very well, however I need to create and

16472 views
4 replies, 4 years ago
Problems using SET QUERY_BAND from ODBC Topic by tucker.cahooter 12 Oct 2015 odbc, query_band, transaction

I am having problems using the SET QUERY_BAND via ODBC. I need to use it followed by a SELECT statement in a production context. I am not at liberty to change the SQL code nor post the actual code, but I have created a very basic equivalent to illustrate the problem.
If I use the following code
SET QUERY_BAND='pattern=PR%;' UPDATE FOR SESSION;

883 views
9 replies, 4 years ago
.net access to the native CLI Topic by mmccurrey 31 Mar 2011 .net cli c#

Is anybody directly accessing the native CLI api's instead of using the .net provider?

3612 views
1 reply, 4 years ago
Connecting from R via RJDBC and terajdbc4.jar fails Topic by Uwe.Bombosch 28 Aug 2015 r, rjdbc, teradatar, terajdbc4, jdbc

My company is running an R-Studio Server Pro on a Red Hat Linix 6 platform (64bit) and a Teradata 14 RDBMS. When trying to connect via RJDBC, I get an error that seems to be well known in the forums, but the standard recipes for resolving the issues don't help. Here is how I connect to the Teradata DB:

1538 views
3 replies, 4 years ago
Sqoop Import from Teradata with 30 lines of SQL query using –query is failing Topic by sguthi0910 10 Jan 2014

Hi,

 

I was trying to import data from teradata into hadoop using sqoop command. This import includes joining of tables on teradata and import the results to hive. I'm using the --query option of sqoop to insert the SQL query. The SQL query which I'm using is more than 30 lines. The import is failing with the following error.

 

11079 views
11 replies, 4 years ago
Teradata connection Error Topic by asridhar7 01 Jul 2013 jdbc, Connection error

Hi,
 
i am trying to connect to Teradata using JDBC from my Linux server using Pentaho and i get the following error.
can you please help
GSSException: Failure unspecified at GSS-API level (Mechanism level: UserFile parameter null)
        at com.teradata.tdgss.jtdgss.TdgssParseXml.<init>(Unknown Source)

5722 views
5 replies, 4 years ago
Teradata odbc connection and tmp space Topic by wjblack 03 Nov 2015 tempspace

I'm trying to understand if there's a setting in Teradata that controls the tmp space when a Teradata connection is configured using Teradata.

261 views
1 reply, 4 years ago
JDBC4 - RAR7115: Unable to set ClientInfo for connection Topic by bretones 04 Nov 2015 jdbc, jdbc4

Keep getting this INFO Level Log in my Glassfish Application Server.
Some research show me that this behavior is related to a method called getClientInfoProperties() when this method is not fully implemented.

435 views
0 replies
Problem with unixODBC and teradata Topic by makaveli0129 20 Jul 2011 teradata, odbc, python, unixodbc

Ok the setup is RHEL 5 with unixODBC 2.2.11 python 2.4 using pyodbc 2.1.5

I have followed the instructions located here:

http://cjgoldsmith.blogspot.com/2011/03/teradata-odbc-python-pyodbc-on-fedora.html

To try and get this working but with no luck. I can get sql server and mysql working and everything like that but just can't get teradata to work. I've tried downloading and using the 13.0 bundle and the 13.10 bundle linking the files and everything like that. When i look at the trace it looks like this:

[code]
ENTER SQLSetEnvAttr
SQLHENV 0x13a13830

9803 views
6 replies, 4 years ago
Issue with connection using RODBC to Teradata Topic by EUsha 23 Jul 2015

I am facing this issue on Red Hat Linux Server while connecting using R onto Teradata 14.10.
I am using R-3.2.1 and Teradata 14.10 client. Also installed RODBC package.
Below is the error I am noticing:
$ R
> library(RODBC)
> db <- odbcConnect("testdsn", uid = "userid", pwd = "password")
Warning message:

1013 views
1 reply, 4 years ago
adodb connection error - Not enough information to log on Topic by jahotchkin 23 Oct 2015 vba, adodb, dsn, odbc, integrated security, not enough information

I can connect to a Teradata db instance using a DSN entry.  When I reference that same DSN entry in an adodb connection string the .Open command generates the error "Not enough information to log on"  
 

    Dim conn As New ADODB.Connection

    

    conn.ConnectionString = "DSN=TDFADS_SYS" 

    conn.Open

1175 views
2 replies, 4 years ago

Pages