All Forums

Covers all topics related to Teradata database connectivity, including the use of client technologies such JDBC, ODBC, .NET Provider etc. For articles, blogs and more, see the Connectivity section of this site.

You must login to post to the forums.
Unable to Connect to Teradata Database from Teradata Studio on iOS (Mac) Topic by sargofco72 02 Aug 2016

Hello Guys, I am to attempt to connect to a remote TERADATA Database from the Teradata Studio from my Mac. The error reported is showed below and this same error happened from the Linux Operating System. But if I configure a DNS in Windows I can connect to the Remote Teradata when the connection testing is executed.

146 views
2 replies, 3 years ago
Teradata Birt JDBC datasource creation Topic by haunties 15 Apr 2015

Hi,
I'm on a windows 7 in 32 bits and I use Eclipse IDE for Java EE developper and I install Birt framework manually.
 
I want to use a datasource connected with a teradata database.

1033 views
1 reply, 3 years ago
Querying teradata with UDF from Excel Topic by mark123 28 Jul 2016

I have problem executing query accessing Teradata UDF from Excel. Query executes fine from SQL Assistant but when executed from Excel 2010 it fails and DBQL logs an error message. Query looks like this:
SELECT top 70 from SIM_DATA.udf_ForecastPerion(CAST (sv.EventDate as DATE)) AS SPF_ForecastPeriod
FROM SIM_DATA.ShopVisit sv
and DBQL logs error: 3706 Synatx Error

78 views
1 reply, 3 years ago
Cloudera Connector Powered By Teradata Topic by indra91 29 Jul 2016

The cloudera connector powered by Teradata is used to export the data from teradata systems to Hadoop using Sqoop.I would like to know how it maintains read-consistency while reading the data from the table?Does it aquire locks on the table?

116 views
0 replies
ODBC Connection Error - Specified driver could not be loaded Topic by brydgesk 03 Apr 2012 odbc

I installed the most recent ODBC driver earlier today (Windows XP 32-bit, ODBC version 14.00.00.04), and immediately lost the ability to connect via ODBC, in Teradata SQL Assistant. The error I receive is:

160: Specified driver could not be loaded due to system error 126 (Teradata)

53144 views
13 replies, 3 years ago
connecting to Teradata from Oracle DB &SAP BW Topic by Raj Y 15 Jul 2016 oracle, sap bw, TD

Hello Everyone,
 
i am doin a POC by  connecting to Teradata DB from Oracle DB and SAP BW to transfer the data from Oracle and SAPBW. Is it possible ? if yes, please guide me how to do that ?
i am using TD 15 version.
Thanks in advance,
Raj Y

224 views
1 reply, 3 years ago
Can not connect from host to TDE 14 40G - IP address is not set. Topic by sharonn 13 Jul 2016 40g, tde, vm, host

Hi,
I was using the TDE 14 - 4G successfully but could not load my data due to free space.
Now I’m trying to work with TDE 14 – 40G but I can’t connect to the VM from my host.
No eth0 IP address was set on the VM – so I tried configuring my own IP and succeeded to ping the VM.
But - I still can’t connect to Teradata from Teradata studio or from putty on my host.

134 views
1 reply, 3 years ago
164 views
0 replies
Teradata Kerberos : Failure server not found in kerberos database Topic by prasaddhoble 25 Jun 2015 kerberos

Hello All,
We are trying to setup Kerberos client on a Teradata VM. We have followed all the steps mentioned in info.Teradata
We stuck at the last step. When we try to login. we are getting error as 

1022 views
3 replies, 3 years ago
Ping Failed - can not connect to Teradata on Linux - aws Topic by sharonn 06 Jul 2016 ping failed, AWS, pdestate, System is operational without PEs, Sessions are not allowed, connect

Hi,
I’m using Teradata Express on linux machine - aws.
When starting the machine, Teradata is not starting properly.
I have to stop it and start it several times until Teradata works fine.
Today it did not start at all...
When I type this command:
pdestate –a
I get this state:
PDE state is RUN/STARTED.

240 views
4 replies, 3 years ago
ODBC error (64bit) Topic by timlisa20 27 Jun 2016

Hoping someone can help with this issue as I have spent way too long trying to troubleshoot on my own.
I have the latest version of Teradata Studio(15.11) and I am running Windows7(64bit).

312 views
2 replies, 3 years ago
JDBC Fastload Error Tables Topic by tmak 18 Jun 2014 jdbc fastload

Is there a way to redirect where the error tables are created in a JDBC Fastload operation?
My scenario is loading a staging table in a schema/database where the ID doing the load does not have CREATE TABLE privs. As per company standards the error tables are typically created in a separate database.
As an example, my SQL statement is of the form:

1029 views
3 replies, 3 years ago
Error while setting up proxy user using BO Topic by teradatauser2 30 Jun 2016

Hi,

 

I am working to set up a proxy user to connect from BO to teradata. I am able to test this using sql assistant. Basically, i am executing two commands :

 

 1.Grant connect through idw_bo_user to permanent "samir.singh" with role myrole; - This sets up a connect through for user "samir.singh" using "idw_bo_user".

 

165 views
0 replies
Teradata ODBC driver with Apache/PHP Topic by bobomagic 10 Aug 2007

Has anyone successfully setup and run an Apache/PHP environment with the Teradata ODBC driver?I can get everything running, but odbc_connect() PHP calls result in segfaults in Apache. It's strange, because running php from the command line with the same php script works fine.

65896 views
26 replies, 3 years ago
Teradata JDBC Exception Topic by rajgo_it 03 Mar 2011 jdbc exception

Hi all, i am new to this forum. I need your help on a issue of a Java application which we are facing into production. The app is talking with teradata db (v 12) via JDBC api; It is working fine, but recently app is unable to talk with db in few instances. I have got below exception in catalina.out file. Appreciate if anyone can put light on the issue.

Exception:

INFO | jvm 1 | 2011/02/21 14:32:21 | 2011-02-21.14:32:21.306 TERAJDBC4 ERROR [pool-3-thread-2] com.teradata.jdbc.jdbc_4.TDSession@2ea70c Read message 1: Incomplete LAN message header: read 0 bytes

18843 views
15 replies, 3 years ago
python / odbc connection to TD Topic by vijaynori 21 Jun 2012 teradata, odbc, python

 

Windows setup: tdodbc__windows_i386.14.00.00.04.zip (tdicu, TeraGSS, tdodbc), Python-2.7.3, pyodbc-3.0.3

 

I am able to extract data from using tdxodbc.  The following piece of python code also works fine -- 

 

========

>>> import pyodbc

7487 views
2 replies, 3 years ago
Command line installation for ODBC Driver for Windows 15.00.00.00 Topic by ndasilva@bunnings.com.au 29 Oct 2014 odbc, driver, command line, install, installation, windows

Hi,
 
I am trying to package the ODBC driver for installation at our company and am encountering some issues with setup.exe. The GUI claims it is installshield but all the usual command line arguements are not working. I jsut get an error "The setup command line is invalid. The setup cannot proceed".
I have tried ...
 
setup.exe /r
setup.exe /s

2158 views
5 replies, 3 years ago
ODBC performance on Linux Topic by Johannes Vink 03 Jun 2016 odbc, microstrategy, performance

Hi all,
We are experiencing a relative slow ODBC throughput from TD to Microstrategy and I am wondering if this is "as good as it gets" or if the throughput is below standard.
The challenge is that TD is performing nice, but the transfer time of the output of the query is taking a significant time of the total run time of the report. We have tested with the following setup:

487 views
1 reply, 3 years ago
Teradata JNDI connectivity Topic by rajivgupta1107 02 Dec 2009

Hi,We have teradata12 installed on my machine. I am trying to connect to teradata from a java application. When i try to connect through JDBC, i can connect. But when we try to connect using jndi, i am getting the error as:Error occured while trying to connect to the databaseInvalid JNDI connection stag : [Teradata JDBC Driver] [TeraJDBC 12.00.00.110] [Error 1000] [SQLState 08S01] Login failure for Connection to 10.20.26.212:1025 Wed Dec 02 16:31:58 GMT+05:30 2009 socket cid=5113f0 sess=0 java.net.UnknownHostException: 10.0.6.212:1025 at java.net.Inet4AddressImpl.lookupAllHostAddr(Native Method)JNDI is defined as:stag/type=javax.sql.DataSourcestag/driver=com.teradata.jdbc.TeraDriverstag/url=jdbc:teradata://10.20.26.212:1025/dbcstag/user=abcstag/password=abc123Please let me know if i am missing any step.Regards,Rajiv Gupta

13461 views
6 replies, 3 years ago
Perl to TERADATA connection via DBD::Teradata using kerberos Topic by SAP 26 May 2016 perl, teradata, kerberos, DBD::Teradata, tdat_security

Hi , 
I need to connect to teradata from perl without using password [ kerberos ] via the module DBD::Teradata . I have acheived it via ODBC but didnt have a clue for  DBD::Teradata  ,other than , it can be accomplished via tdat_security . I am not sure how to use it . Please help . 

269 views
0 replies
hive server2 connection through Teradata Studio not working Topic by mandalapusri 24 May 2016 Apache Hive

What could be the reason for the below error.
Error

223 views
0 replies
ODBC connect to DB2 in TPT - TPT_INFRA: TPT02192: Error: Cannot load shared library Topic by sboxtops 21 May 2016

Hi,
 
I'm writing a TPT script to connect to DB2 with ODBC. The ODBC DB2 drivers are 64 bit. I'm running on AIX unix. Below is the error, some teradata libraries, and the tpt script. Please let me know if you need any additional information. Thank you for your help.
 
/home/idxxx >> tbuild -f load_db2_connect.tpt

206 views
0 replies
Teradata Python Module: fails on first attempt, succeeds on 2nd Topic by teb 25 Mar 2016 teradata python module, odbc, #Connectivity, Socket error

I am new to python, and am finding that my first attempt to connect via ODBC always fails with the error you see below, however the 2nd attempt, immediately afterwards, always succeeds, and does so pretty quickly.  Any thoughts on why this might be?  I would like to test to for a successful connection in a loop, like with a 'try' statement, but not sure how to do that.

492 views
2 replies, 4 years ago
Connectivity error to TD using ODBC_64 on library libtdsso.so Topic by yonaker 17 May 2016 odbc, TDXODBC, libtdsso.so

Hello, I have installed TD 14.00 on a RHEL server and trying to connect to a TD server using TDXODBC.  I just ran a strace and am getting the following error.  It appears that this is happening during logon and then aborts.  Can anyone enlighten me as to what this library is, related error and suggestion to how to fix?  Any assistance is greatly appreciated. 

320 views
1 reply, 4 years ago
Can not connect to TD from SQLA over home network, but can connect using BTEQ! Topic by dhananjay53 01 May 2016

I have set up TD (rel 15.10.00.06, ver 15.00.00.07)  under VMPLAYER on a Windows 8.1 laptop connected to my home network. . I can access TD from Studio Express, BTEQ running under VMPLAYER on this laptop. IFCONFIG running on a GNOME terminal under VMPLAYER shows eth0 inet addr as 192.168.1.2. 

1297 views
9 replies, 4 years ago

Pages