All Forums Connectivity
brydgesk 6 posts Joined 08/11
06 Apr 2012
Visual Studio 2010

Do people actually have the .NET Data Provider for Teradata integrated in Visual Studio 2010? I know you can add a reference to the driver and write code against it, that works fine. I'm talking about integration, where Teradata shows up in the Data Source list when creating things like Entity Framework Data Models.

I've seen this thread: teradata-net-provider-for-visual-studio-2010-net-4-0

Which seems to indicate that the driver doesn't natively support VS2010 integration, but that you can update the machine.config file to do it manually. I've updated that file but still don't have Teradata showing up in any Data Source lists.

I've also seen this article: creating-an-odata-service-using-net-data-provider-for- teradata

Which casually refers to using VS2010 with Teradata, and makes no mention of any steps necessary to add functionality. In that guide he just creates an ADO.NET Entity Data Model object against a Teradata connection, which is not available to me as an option.

NetFx 346 posts Joined 09/06
10 Apr 2012

The .NET Data Provider for Teradata version integrates with the Visual Studio 2010 Pro or higher. The .NET Data Provider for Teradata installation adds registry keys to HKLM\Software\Wow6432\Microsoft\VisualStudio\10.0\DataProviders, DataSources and ...

The "About Microsoft Visual Studio" dialog box (accessible from the Help menu) should have an entry for the ".NET Data Provider for Teradata".

The "Custom" installation options displays "Visual Studio 2010 Integration" option only when it detects Visual Studio 2010. So I recommend that you use "Custom" option to verify that the Installation detects VS 2010 and it adds the registry keys.

It is very hard to diagnose the problem remotely; perhaps you should open an incident.



brydgesk 6 posts Joined 08/11
11 Apr 2012

Hmmm, I only saw Visual Studio 2008 when I installed (I have both 2008 and 2010 installed). My 2010 is the Express edition, so perhaps that is the reason.

I actually manually created all of the registry keys I found for 2008 in the 2010 folders, with no success. I'm sure I just missed some, though. Thanks for your help!

29 Jul 2013

Hi.  I am having a similar problem with VS 2010 and TTU.  I have Windows 7-64 installed and when installing the TTU, no registry keys are added in HKEY_LOCAL_MACHINE\SOFTWARE\TERADATA.  I downloaded the 32 & 64  bit ODBC installation packages and installed them individually.  Now, I can  see the registry keys for those packages.  Still nothing for the rest of the TPT tools, however (I did the "typical" install).
I downloaded and installed the Attunity 2.0 package and the the following error when trying to execute a data transformation using the MSTERA data connection.

[Teradata Destination [131]] Error: The Teradata TPT registry key cannot be opened. Verify that the TPT API 12.0 or 13.0 Edition 2 ( for Windows x64 is installed properly.


Anybody have an idea how to get those keys installed?




Below is a dump of my registry entry under TERADATA:


Windows Registry Editor Version 5.00






[HKEY_LOCAL_MACHINE\SOFTWARE\Teradata\Certlist\ODBC Driver for Teradata nt-x8664]




[HKEY_LOCAL_MACHINE\SOFTWARE\Teradata\Certlist\Shared ICU Libraries for Teradata nt-x8664]









[HKEY_LOCAL_MACHINE\SOFTWARE\Teradata\Client\13.10\ODBC Driver for Teradata]


"InstallPath"="C:\\Program Files\\Teradata\\Client\\13.10\\ODBC Driver for Teradata nt-x8664\\"



[HKEY_LOCAL_MACHINE\SOFTWARE\Teradata\Client\13.10\Shared ICU Libraries for Teradata x8664]

"InstallTimeStamp"="7/17/2013 9:14:54"

"InstallDLLPath"="C:\\Program Files\\Teradata\\Client\\13.10\\Shared ICU Libraries for Teradata\\lib\\"






"VERREGLOC"="HKEY_LOCAL_MACHINE\\SOFTWARE\\Teradata\\Client\\13.10\\Shared ICU Libraries for Teradata x8664\\Version"



"InstallDir"="C:\\Program Files\\Teradata\\Teradata GSS\\"


[HKEY_LOCAL_MACHINE\SOFTWARE\Teradata\Teradata GSS\nt-x8664]



[HKEY_LOCAL_MACHINE\SOFTWARE\Teradata\Teradata GSS\nt-x8664\]




You must sign in to leave a comment.