All Forums Connectivity
pindiganti2 3 posts Joined 05/14
04 May 2014
Unable to connect to teradata

Hi All,
I am new to Teradata. I have knowledge on Oracle. Recently I installed Teradata 13 version on my lap through VM. I completely installed Teradata tools and utilities. Now I am not able to connect to Teradata through SQL Assistant. While I tried to connect it's showing Error. Below the error log:
 

5/4/2014 2:51:46 PM

SQLA Version: 13.0.0.8

System.AccessViolationException

Attempted to read or write protected memory. This is often an indication that other memory is corrupt.

   at Teradata.SQLA.OdbcConnectInfo.SQLDriverConnectW(IntPtr hdbc, IntPtr hwnd, IntPtr szConnStrIn, Int16 cbConnStrIn, IntPtr szConnStrOut, Int16 cbConnStrOutMax, Int16& pcbConnStrOut, Int16 fDriverCompletion)

   at Teradata.SQLA.OdbcConnectInfo.GetConnectString() in F:\ttu130_efix_snap\tdcli\qman\sqla\ OdbcConnectInfo.vb:line 89

   at Teradata.SQLA.OdbcConnectInfo.Connect() in F:\ttu130_efix_snap\tdcli\qman\sqla\ OdbcConnectInfo.vb:line 175

   at Teradata.SQLA.MainFrm.ConnectMenu_Click(ConnectInfo cn) in F:\ttu130_efix_snap\tdcli\qman\sqla\MainFrm.vb:line 936

   at Teradata.SQLA.MainFrm.ToolbarMgr_ToolClick(Object sender, ToolClickEventArgs e) in F:\ttu130_efix_snap\tdcli\qman\sqla\MainFrm.vb:line 551

****************************************************** *

 

Can someone help me out please..

 

 

Regards,

Venkat

MikeDempsey 94 posts Joined 10/06
05 May 2014

The version of SQL Assistant that you are running is almost 5 years old. The latest version for TTU 13.0 [still old] is 13.0.0.16.
You can however use newer versions of SQL assistant with older versions of the database, and TTU. 
The latest version is 15.0.
I don't see any fixes for connection problems in the 13.0 efixes higher than the one you are running.
The line where it fails is when it calls the main connect function in ODBC so there is a very good chance that the error is occuring in ODBC rather than SQL assistant.
[If the failure occurs after it displays the data source selection dialog then it definately occurs in ODBC, otherwise it might be in either]
The only thing I can think to check would be that you have installed [and created data sources for] the 32bit version of ODBC rather than the 64bit version.
I would suggest upgrading to a newer version of SQL Assistant - and probably to newer versions of ODBC and the rest of the TTU stack. 

flash7gordon 29 posts Joined 05/10
05 May 2014
conStrBuilder.DataSource = "tdserver.com";
                conStrBuilder.Database = "mydb";
                conStrBuilder.UserId = "myuid";
                conStrBuilder.Password = "mypw";
                conStrBuilder.AuthenticationMechanism = "TD2";

Venkat,   that memory error is nasty and I concur with Mike that you need to be higher than that to make some progress.   I would add that the higher versions of  the teradata client are free and publicly available.  You don't want to go higher than you datbase though and you can see that with:
 
select * from dbc.dbcinfo
 
once you get past that you need to understand what kind of connectivity the database has in your environment.   The older connectivity is a unique teradata userid and looks like what is shown above.   If you use your windows password to log on to teradata then you would need to change the AuthenticationMechanism to LDAP
 
 

pindiganti2 3 posts Joined 05/14
05 May 2014

I removed TTU 13 and I reinstalled TTU 14 on my 64bit OS. Still I am facing same issue.

pindiganti2 3 posts Joined 05/14
25 May 2014

10061 WSA E connection refused: Teradata server not accepting the connection
 
receiving the above error while logging to Teradata SQL Assistant. Please help me someone.

Amanpreet 1 post Joined 06/12
18 Sep 2014

I am also getting the same error from TTU 15. Any solutions?

rharitha7 8 posts Joined 09/15
04 Sep 2015

I am aslo getting the same error. Can someone here help me?
Thanks in advance.

You must sign in to leave a comment.