All Forums Connectivity
Sociodude 1 post Joined 06/06
28 Jun 2006
Trying to set up ODBC connection

I've been trying to set up the ODBC connection for Teradata while using the program Advanced Query Tool. I've already downloaded the latest driver and installed it on the computer. When I go to add a new system data source and click on teradata, it gives me the following error message: "Unknown error occurred in terasso library."Then it pulls up the window that allows me to enter information such as name, description, Teradata Server Info, Default database, Username, Password, and Account String. After entering this information, I get another error message: "Unable to write Accountstring into private profile."Does anyone have any ideas?

Phani 15 posts Joined 07/04
29 Jun 2006

What TTU are you using? Before installing the ODBC driver, there are other dependencies such as TDICU and TeraGSS packages. These need to be installed first before installing ODBC driver.

Uwe Posselt 3 posts Joined 07/06
20 Jul 2006

Hi,I have the same problem. The newest ODBC driver (6/28/2006 11:25:48 AM) can be downloaded at "http://www.teradata.com/t/go.aspx/index.html?id=152251"But where I can download the "Teradata Generic Security Services" (TeraGSS) and the "Shared common components for Internationalization for Teradata" (tdicu)?Best Regards,Uwe Posselt.

Fred 1096 posts Joined 08/04
20 Jul 2006

The driver download file is actually a self-extracting "bundle" that includes the appropriate TeraGSS and TDICU as well as the driver itself.

Uwe Posselt 3 posts Joined 07/06
21 Jul 2006

Ok, thank you for the information.The package contains TeraGSS 06.01.00.00, TDICU 01.01.01.00 and TDODBC 03.05.00.05Meanwhile I've got a newer TeraGSS 06.01.00.14 by a NCR supporter. I don't know, why the ODBC package (from 6/28/2006) contains a TeraGSS version, that is older than 11/22/05.This is the fix list for TeraGSS:***************# Copyright 2006, NCR Corporation. All rights reserved.#ident "$id$"Problems fixed by this release are listed below (latest at the top): ---------------------------TeraGSS / tdgss 6.1.0.x EFIX DRs----------------------------This is a list of all DRs included in this product since the 6.1 GCA release.***************************************************************************************************************** EFIX 6.1.0.14 created 03/14/06 ***********************************************************************************************************DR 101738 Priority 1 Users complain that the encrypted logons take twice as long as non-encrpyted logons.***************************************************************************************************************** EFIX 6.1.0.11 created 02/20/06 ***********************************************************************************************************DR 100608 Priority 1 Gateway enters a crash loop with ldapv3_stricmp() at the top of the traceback when logdata does not contain a user= property.****************************************************************************************************************** EFIX 6.1.0.9 created 01/27/06 ***********************************************************************************************************NOTE: This efix contains the rollup of code from 06.00.02.07DR 97432 Priority 2 ODBC applications (kxen) fails to connect to a V2R5.1.x RDBMS.DR 99109 Priority 2 DBS node runs out of memory and hangs.******************************************************************************************************************* EFIX 6.1.0.07 created 12/29/05 *********************************************************************************************************DR 99554 Priority 2 After each logon, a ldap client stays in ESTABLISHED and turn to CLOSE_WAIT around 15 minutes later. These connections are never freed until the gateway or query director process terminates. After enough logon attempts, the end result makes the Teradata server or Query Director unavailable, effectively denying service to legitimate clients.DR 99921 Priority 2 After certain types of logon error have occurred when using Kerberos, further Kerberos logons are permanently disabled. All attempts to use Kerberos fail.******************************************************************************************************************* EFIX 6.1.0.06 created 12/21/05 *********************************************************************************************************DR 100303 Priority 2 In order to support the Microsoft 8.0 concept of manifest files which was introduced in the "official" release of the 8.0 compiler, the TeraGss package needed to be updated to support the manifest file concept and how it packaged the C run-time routines.******************************************************************************************************************* EFIX 6.1.0.04 created 11/22/05 *********************************************************************************************************DR 100213 Priority 2 TeraGss Client nt-ia64 package installs in a folder created with the name nt- x8664. Also the version number in the setup says 6c and Add/Remove programs says the version is 6c.0 06.1.***************

munir.parikh 3 posts Joined 10/06
24 Oct 2006

I'm facing the same problem it says "Unknown error occurred in terasso library".I uninstalled ODBC from my laptop and installed latest version 03.05.00.05 and GSS and ICU bundled with it but still my problem is not resolved.Can anybody help me in fixing this issue.Thanks in Advance,Munir

Uwe Posselt 3 posts Joined 07/06
25 Oct 2006

Have you installed the drivers in the correct order (1. GSS, 2. ICU, 3. ODBC)Which windows version are you using?

SocioProgrammer 1 post Joined 08/05
25 Oct 2006

When I eventually solved the error, I think I remember it having to do with permissions. I didn't have the permission to access a connection that someone else had set up, I think. Look at your permissions.

munir.parikh 3 posts Joined 10/06
25 Oct 2006

Yes brother ... ordering worked perfectly fine for me ...Special thanks to Uwe Posselt!!!Regards,

Tariq 18 posts Joined 08/06
14 Feb 2007

This helped me as well. Thanks guyz.

caldreamin 1 post Joined 07/08
23 Jul 2008

I am having the same problem and nothing has worked. I have uninstalled all of the Teradata software including the terasso.dll file. Rebooted the pc (more times than I can count) and have tried to install the drivers in the order suggested (GSS, ICU, ODBC) and still get the terasso error. No one else in my workgroup is having this problem and we are all running Windows XP. Help!

munir.parikh 3 posts Joined 10/06
23 Jul 2008

did you uninstall ODBC, GSS and ICU before reinstalling them?1) Uninstall ODBC, GSS, ICU2) Install them in correct sequence -> GSS -> ICU -> ODBC

Fred 1096 posts Joined 08/04
24 Jul 2008

Some uninstall did not work properly. Search your hard drive for multiple copies of the terasso.dll file and remove old ones manually.

sRavanSarma 23 posts Joined 11/08
23 Aug 2009

Thanks Uwe Posselt, Man your suggestion worked really good.I have been facing issues with this problem for a long time and today got rid of it.Thank you very much

Yves Pouliot 1 post Joined 02/10
27 Apr 2010

Update for TD13
I had the same problem going from TD12 to TD13. (Cannot find terasso library and cli utilities giving a teragss error)
This problem was caused by TeraGSS not being installed properly.
A easy way to check if it's the cause of your problem is to run the command "tdgssversion" from the directory:c:\Program Files\NCR\Teradata GSS
"nt-i386\xx.xx.xx.xx" (the TeraGSS version just installed).
You should see an asterix after the new version number: xx.xx.xx.xx *.

If you don't see any * or the * is paired with an old version then the problem is there.
Execute the following under the above new TeraGSS directory:
"tdgssversion -switch xx.xx.xx.xx" (the new version) or
"run_tdgssconfig"
Usually you will heard a loud beep at the cmnd completion.
Rerun tdgssversion to verify the * has been switched to the current version. If yes then the problem is resolve.

You may receive the error message: lclient symbolic link could not be deleted.
In this case you need to uninstall (start/ctrl panel/ remove program) all teradata gss program and reinstall the new one.
In my case I had to install two new version of the same release (ex 12.00.02.22 and 12.00.03.01) to get away with the Lclient symbolic link error.
Also make sure your user have write permission on those directories.

Sasank 1 post Joined 05/10
02 May 2010

I am new to teradata...... Can any one please send me step by step instrictions of how to set up the teradata database?

Sorry to ask you this but if somebody could send this to me that would be very helpful to me.

Thank you
nimmagadda.sasank@gmail.com

rehnaraj 11 posts Joined 06/10
07 Jun 2010

Hi ,
I have installed teradata SQl assistant java edition on my pc,but not able to make connections.Its is giving error "could not connect to teraata database"

Please help me.M a beginer.

jp555 1 post Joined 08/10
27 Aug 2010

Hi,

I am facing the ODBC driver installation issue while installing the teradata sql assistant-version 12.0.0.07. Can any one help me to resolve this issue.

naveen.huttad 1 post Joined 10/10
27 Apr 2011

While installing TD ODBC 13 specifically the ICU Library I am gettin the below error
Error 1720 There is a problem with this windows installer package. A script required for this install to complete could not be run. contact ur support personel or package vendor. Custom action Unins_prev_x64 Script error - 2146828235

Please help
Nav

InstallDev 4 posts Joined 11/10
10 May 2011

Try using the latest TDICU.13.00.00.06 package. The issue observed was fixed in this particular version.

ktrock 1 post Joined 12/10
10 May 2011

It seems that 13.00.00.05 is the latest available (5/4/2011). That gets me thru the ICU install but gives me that same error when trying to install the ODBC itself.

"A script required for this install to complete could not be run. contact ur support personel or package vendor. Custom action Unins_prev_x64 Script error - 2146828235"

sinkzink 3 posts Joined 05/11
11 May 2011

I have occured same error "Unins_prev_x64 Script error - 2146828235".
my enviroment is win2008 server R2 64bit.

sinkzink 3 posts Joined 05/11
11 May 2011

I saw error log at %TEMP% Folder.

logfile recorded following message.
------ from -----
Error 1720.There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor. Custom action Unins_prev_x64 script error -2146828218, Microsoft VBScript 実行時エラー: 書き込みできません。 Line 165, Column 1,
=== Logging stopped: 2011/05/11 22:02:33 ===
----- end -----

「実行時エラー: 書き込みできません。 」 means can't write access to filesystem.

sinkzink 3 posts Joined 05/11
11 May 2011

Sorry, i resolved problem by booted setup.exe administrator mode.

rmpatil 2 posts Joined 08/11
13 Sep 2011

I have installed the teradata ODBC driver along with the teraGSS and tdicu. I can go to the step where I should now configure my ODBC driver. I am completely new to deal with teradata and am trying to figure out whats the best way to test my connection. Is the DNS name of the terdata server enough to be able to connect to the database? Dont I need like any port number or source name to plug into teh configuration?Alos I noticed that the configure window does not give me a button to test connection...any ideas?

 

I will highly appreciate any input around this.

 

rmpatil 2 posts Joined 08/11
13 Sep 2011

I am sorry - I forgot to mention that I have installed the ODBC driver on a 64-bit windows server.

GarethKirk 1 post Joined 10/11
07 Nov 2011

Was anyone successfull in creating a valid connection via the ODBC connection? What settings did you use? How would you reommend setting up the connection?

 

Mcdonald_t 4 posts Joined 01/12
13 Jan 2012

Help, I am trying to install on a Windows 2008 Server 64 bit. I have downloaded the 64 bit driver but I am still getting the error: 2738 Could not access VBScript run time for custom action.

InstallDev 4 posts Joined 11/10
17 Jan 2012

You might be getting this error on a Windows 2008 64-bit Server because the vbscript runtime library is not registered correctly. Try registering the library using the following commands from command prompt.

c:\>c:\windows\system32\regsvr32.exe c:\windows\system32\scrrun.dll

c:\>c:\windows\syswow64\regsvr32.exe c:\windows\syswow64\scrrun.dll

Try installing the ODBC Driver package after this.

 

 

 

 

dennisfortier 4 posts Joined 10/11
05 Mar 2012

We are upgrading our database from V12 to V13.10.  In preparation for our upgrade, we have upgraded our TTU components to 13.10.  We have also installed Viewpoint to replace Teradata Manager, TDWM, ect.

It looks like the effort to upgrade desktop ODBC drivers from 12 to 13.10 across our enterprise will not be complete when the database is upgraded to V13.10.

The documented Teradata Roadmap shows TTU 12 is compatible with database releases 1  forward and 2 backwards.

I don't have a test system with the database upgraded to V13.10 yet to test if ODBC Driver 12 works with database V13.10.  I'm trying to plan for the effort ahead.

I know it's not documented or supported, but does anyone currently have an 12 ODBC driver accessing a V13.10 database successfully?   

rameshp4567 1 post Joined 08/12
31 Aug 2012

please tell me how uninstall teradata 13

eugenegolubtsov 1 post Joined 01/13
15 Jan 2013

Hi,
I am new to Teradata, but have 20 years in IT.
I am installing a 14.0 clinet, I belive it's 14.0000.02 client.
My company is runing XP 32bit on there desctops.
I am new to the team, everyone else had no problem installing it.
 
But, for me.. when I install it, everyhting runs fine.
No errors. But ODBC driver does not show up on the ODBC list.
And there are no changes in regestry for the Teradata driver.
Can someone help me trobleshoot this problem ?
I have been at it for 2 days.
Left a phone msg on Teradata answering service.. do not hjav eany resolution so far.
Thanks for any assitance.
 

You must sign in to leave a comment.