All Forums Connectivity
tanzir 1 post Joined 08/14
01 Sep 2014
Teradata Hadoop Connector (HDP 1.3.3) - Schema definition is invalid

Hello everyone,
This is the first time I'm trying to use Teradata Hadoop connector for Hortonworks Distribution (HDP 1.3.3) but looks like I'm missing something. I tried with 2 different versions of connector but both of the time I'm getting the same error "Schema definition is invalid" from the method: com.teradata.hadoop.utils.TeradataSchemaUtils.setupOut putSchema. Can anyone please tell me what I'm doing wrong here? Any information will be highly appreciated.
Here is the complete log:
 

14/09/01 20:39:06 INFO mapreduce.TeradataOutputProcessor: job setup ends at 1409629146472

14/09/01 20:39:06 INFO mapreduce.TeradataOutputProcessor: job setup time is 1s

14/09/01 20:39:06 ERROR teradata.TeradataSqoopExportJob: Exception running Teradata export job

com.teradata.hadoop.exception.TeradataHadoopSchemaExce ption: Schema definition is invalid

        at com.teradata.hadoop.utils.TeradataSchemaUtils.setupOut putSchema(TeradataSchemaUtils.java:701)

        at com.teradata.hadoop.mapreduce.TeradataOutputProcessor. setupSchemaMapping(TeradataOutputProcessor.java:334)

        at com.teradata.hadoop.mapreduce.TeradataBatchInsertOutpu tProcessor.setupSchemaMapping(TeradataBatchInsertOutpu tProcessor.java:99)

        at com.teradata.hadoop.mapreduce.TeradataOutputProcessor. setup(TeradataOutputProcessor.java:59)

        at com.teradata.hadoop.mapreduce.TeradataBatchInsertOutpu tProcessor.setup(TeradataBatchInsertOutputProcessor.ja va:60)

        at com.teradata.hadoop.job.TeradataHdfsFileExportJob.runJ ob(TeradataHdfsFileExportJob.java:187)

        at com.teradata.hadoop.tool.TeradataJobRunner.runExportJo b(TeradataJobRunner.java:192)

        at org.apache.sqoop.teradata.TeradataSqoopExportJob.doSub mitJob(TeradataSqoopExportJob.java:253)

        at org.apache.sqoop.mapreduce.ExportJobBase.runJob(Export JobBase.java:276)

        at org.apache.sqoop.mapreduce.ExportJobBase.runExport(Exp ortJobBase.java:392)

        at org.apache.sqoop.teradata.TeradataConnManager.exportTa ble(TeradataConnManager.java:109)

        at org.apache.sqoop.tool.ExportTool.exportTable(ExportToo l.java:81)

        at org.apache.sqoop.tool.ExportTool.run(ExportTool.java: 100)

        at org.apache.sqoop.Sqoop.run(Sqoop.java:145)

        at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java: 65)

        at org.apache.sqoop.Sqoop.runSqoop(Sqoop.java:181)

        at org.apache.sqoop.Sqoop.runTool(Sqoop.java:220)

        at org.apache.sqoop.Sqoop.runTool(Sqoop.java:229)

        at org.apache.sqoop.Sqoop.main(Sqoop.java:238)

14/09/01 20:39:06 INFO teradata.TeradataSqoopExportJob: Teradata export Job completed with exit code 1

14/09/01 20:39:06 ERROR tool.ExportTool: Encountered IOException running export job: java.io.IOException: Exception running Teradata export job

 

 

Thanks in advance.

Tanzir

mohan.indugula 1 post Joined 07/12
24 Nov 2015

Hi,
 
Can you share Sqoop Code.
 
Thanks

You must sign in to leave a comment.