All Forums Connectivity
tdreturn 25 posts Joined 10/12
02 May 2016
TD JDBC Driver Upgrade question

We are currently on TD 14.10 and use the JDBC driver 15.00.00.20. We  are upgrading to TD 15.10 but are not using any features from 15.10. Is it safe to keep using the 15.00.00.20 driver with TD 15.10 database?

tomnolan 594 posts Joined 01/08
02 May 2016

Yes, Teradata JDBC Driver 15.0 is supported for use with Teradata Database 15.10.
 
The entire Teradata JDBC Driver supported platforms matrix is available here on Developer Exchange.
http://developer.teradata.com/doc/connectivity/jdbc/reference/current/platformMatrix.html

tdreturn 25 posts Joined 10/12
02 May 2016

Tom,
Thanks for the response. My question was a little different. Sorry if I was not clear. Can the JDBC driver 15.00.00.20 still work with TD 15.10 if we are not using any new features of 15.10 in our application?
 
Thanks

tomnolan 594 posts Joined 01/08
02 May 2016

>>> Can the JDBC driver 15.00.00.20 still work with TD 15.10 if we are not using any new features of 15.10 in our application?
 
Yes, Teradata JDBC Driver 15.0 is supported for use with Teradata Database 15.10. Yes, Teradata JDBC Driver 15.0 is expected to work with the old features of Teradata Database 15.10. By "old features", we mean Teradata Database features present in Teradata Database 15.0 and earlier.
 
It is not expected or supported for old Teradata JDBC Driver releases to be able to use new Teradata Database features. For example, it is not expected or supported for Teradata JDBC Driver 15.0 to use or work with any new features introduced by Teradata Database 15.10.
 
In order to use new Teradata Database features introduced by a particular Teradata Database release, you must use the corresponding (or newer) Teradata JDBC Driver release. For example, in order to use any new Teradata Database 15.10 features, you must use Teradata JDBC Driver 15.10 or later.
 

tdreturn 25 posts Joined 10/12
09 May 2016

Thanks Tom.

You must sign in to leave a comment.