All Forums Connectivity
Thomas_D_W 2 posts Joined 05/15
02 Jun 2015
.NET Data Provider Teradata - Session Issue - Volatile Table

Teradata Fans,
 
I have a problem with the .NET provider in SSIS & a stored procedure in Teradata. I have developed stored procedure that creates a volatile table. This volatile table will be used during the execution of 1 SSIS package. I have 64 SSIS packages that make use of the same stored procedure in Teradata. All these packages will create 1 volatile table with the same name in Teradata. 
The 64 SSIS packages run parallel in a Master SSIS Package. When I run the Master package a got the error message that the volatile table already exists. This is strange. I thought that every package had a different session? Bottomline: how do I force SSIS to make a new session for every call to the Teradata stored procedure?
Anybody encountered the same issue? 

NetFx 346 posts Joined 09/06
02 Jun 2015

Did you turn off Connection Pooling? It is enabled by default ("Connection Pooling=False;Data Source=X; ... ").

Thomas_D_W 2 posts Joined 05/15
03 Jun 2015

NetFx,Hero! the abouve sollution worked for me. I just needed to add the following property to my connection string: Connection Pooling=False; 
This forces a new session of every call to Teradata.
Thanks, this has been very helpful!

You must sign in to leave a comment.