All Forums Connectivity
hm186001 2 posts Joined 04/10
22 Aug 2011
Connection problems using .NET Data Provider


I am using .NET Data Provider to connect from Microsoft Analysis Services (BI Studio 2008) to Teradata. In general that works fine and I connect to Teradata database systems.

But there is a specific Teradata system (Teradata 13.10) that I am unable to connect using .NET Data Provider.
I always get the following error message:

[TeraGSS Security Library] [115022] Exception occurred in TeraGSS layer. See inner exception for details.

I am using the following connection String:
Database=;Response Buffer Size=65000;User Id=;Data Source=;Persist Security Info=True;Use X Views=False;Restrict to Default Database=True;Data Source DNS Entries=1;Use Enhanced Schema Table=False

When I just replace the IP address to point to a different system (, Teradata 12) it works fine.
So it seems to me not to be a general problem with the .NET Data Provider (version 13.0).
Furthermore I am able to connect to the system at successfully using ODBC, OLEDB and JDBC.

So I am just unable to connect to this specific system using .NET Dat Provider...

Unfortunately I do not know the reason for the problem and I don't know where to look for the inner exception for details (see error message above). Does anybody how to handle this problem?

Thanks in advance!

Best regards,

hm186001 2 posts Joined 04/10
24 Aug 2011

Hi again,

Meanwhile I was able to solve the problem.
Uninstalling the .NET Data Provider and re-installing it (in version solved the problem.

First I tried to use .NET Data Provider version but that did not work. Microsoft Analysis Services had problems with this version. That's why I stepped back to

Best regards,

KQ1024 2 posts Joined 04/14
03 Mar 2016

I am using .NET Data Provider 15.11. Which is the latest version.

You must sign in to leave a comment.