All Forums Connectivity
d.heche 3 posts Joined 05/13
10 Dec 2015
Bug in ODBC driver 15.10

When issueing the following statement

select case when (1 = 0) then 1 else 0 end;

in Teradata Studio 15.00.02 using ODBC Driver Version 15.10 I receive the following weird message:

Executed as Single statement.  Failed [ 
Elapsed time = 00:00:00.000 
 
STATEMENT 1: Select Statement failed. 

When issueing the same statement using ODBC driver version 14 I get the correct result of '1'.
Any ideas? Looks like a bug to me.

d.heche 3 posts Joined 05/13
10 Dec 2015

Well... result would be 0, not 1. Except that, all true.

dnoeth 4628 posts Joined 11/04
10 Dec 2015

You probably mean JDBC 15.10 instead of ODBC :)
I just tried it against a TD 15.10.00.08 using the latest Studio release 15.10.01.201511052035 & the built-in JDBC and it worked as expected, same for ODBC & SQL Assistant.
Can you try it using BTEQ? If it still fails it's probably a parser bug (which might have been fixed already).
 

Dieter

d.heche 3 posts Joined 05/13
11 Dec 2015

Yes, it is the JDBC driver.
I am currently at a point where I believe there may be a general problem that prevents the 15.10 drivers from working on my computer. Other, simple statements are not successful either. I may try to replace them with a newly downloaded version from the TD site.
Dirk
 

You must sign in to leave a comment.