All Forums Connectivity
saintperez 1 post Joined 02/12
07 Mar 2012
ADO.Net 13.11.0.1 Provider hangs when trying to create Entity Model in Visual Studio 2010

Trying to create Entity Framework Model in Visual Studio 2010 but it seems to hang at the point where I select the tables and hit Go. I'm able to open the connection and see the objects in TerraData but never finishes this dialog. 

 

Any help is greatly appreciated. 

NetFx 346 posts Joined 09/06
12 Mar 2012

Did you turn off X-Views?

1- Select "Add Connection ..." in the Visual Studio Server Explorer
2- Click "Advanced..." in the Add Connection dialog box
3- Find "Data Dictionary" section in the Advanced Properties dialog box
4- Change "Use X Views" to false
5- Change "Restrict to Default Database" to true. Note this option will show tables for one and only one Database (see #6).
6- Set "Database" to the Database name for the source tables.

I think this will speed-up the Data Dictionary queries.

Also See Carrie's Blog http://developer.teradata.com/blog/carrie/2010/05/if-you-re-not-collecting-statistics-on-your-dictionary-tables-do-it-now about collecting statistics on the Data Dictionary tables.

arrudaw 1 post Joined 04/12
13 May 2012

Netfx,

I have the same problem to create EF model but neither turn off X views resolved.

Always show the follow message:

""Unable to generate the model because of the following exception: 'An error occurred while executing the command definition. See the inner exception for details.
    [Teradata Database] [3610] Internal error: Please do not resubmit the last request.  SubCode, CrashCode:   0,  3701

How can I fix it?

NetFx 346 posts Joined 09/06
14 May 2012

You will need a patch (e-fix) for the Teradata Database. You can either open a customer incident; or upgrade to the latest version/patch-level of the Teradata Database. 

 

You must sign in to leave a comment.