All Forums Cloud Computing
james 10 posts Joined 06/09
01 Feb 2011
Teradata Initiator Service failed with 4 exit code

Hello - having a problem starting TDE-V (TD13, 1TB).

In my SLES guest I get the following errors when attempting to start TD with the "/etc/init.d/tpa start" command:

# /etc/init.d/tpa start
# Teradata Initiator Service starting...
INFO:
recond[10684]: CRITICAL: TdatTools 29003 #nodeDiscovery(): blli_get_node_list(): g->connectedNodes: -1, errno: 2
Teradata Initiator Service failed with 4 exit code
#

Seems to be choking at a node discovery phase. Has anyone else come across this error? I have tried shutting-down and restarting VMware. Any help much appreciated. Thanks.

rockrathod 2 posts Joined 08/12
21 Aug 2012

Even I am facing the same problem.... 

rockrathod 2 posts Joined 08/12
21 Aug 2012

Hi guys can any one of you help me out in solving this problem

Avid zClouder 14 posts Joined 04/13
29 Apr 2013

Im also facing the same problem..Please share the solution..

Kanda 1 post Joined 07/13
01 Aug 2013

So should this issue still does not have a solution??? Thank you.

sudheer51 7 posts Joined 03/13
21 Mar 2014

After giving the command, wait a minute or so and give the same command again. Keep trying. After a few trails (minutes), the database will be started. Looks weird, but works :- )
 
sles10_sp3:~ # tpareset -f "" -y
PDE not accessible: Cannot open PDE device
sles10_sp3:~ # pdestate -a
PDE state: DOWN/HARDSTOP
sles10_sp3:~ #
sles10_sp3:~ #
sles10_sp3:~ #
sles10_sp3:~ #
sles10_sp3:~ #
sles10_sp3:~ #
sles10_sp3:~ # pdestate -a
PDE state: DOWN/HARDSTOP
sles10_sp3:~ # /etc/init.d/tpa start
Teradata Database Initiator service is starting...
Teradata Database Initiator service failed with 4 exit code
sles10_sp3:~ #
sles10_sp3:~ # pdestate -a
PDE state: DOWN/HARDSTOP
sles10_sp3:~ #
sles10_sp3:~ #
sles10_sp3:~ #
sles10_sp3:~ # pdestate -a
PDE state: DOWN/HARDSTOP
sles10_sp3:~ # pdestate -a
PDE state: DOWN/HARDSTOP
sles10_sp3:~ #  /etc/init.d/tpa start
Teradata Database Initiator service is starting...
Teradata Database Initiator service failed with 4 exit code
sles10_sp3:~ # pdestate -a
PDE state: DOWN/HARDSTOP
sles10_sp3:~ # pdestate -a
PDE state: DOWN/HARDSTOP
sles10_sp3:~ # pdestate -a
PDE state: DOWN/HARDSTOP
sles10_sp3:~ # pdestate -a
PDE state: DOWN/HARDSTOP
sles10_sp3:~ # pdestate -a
PDE state: DOWN/HARDSTOP
sles10_sp3:~ # pdestate -a
PDE state: DOWN/HARDSTOP
sles10_sp3:~ # pdestate -a
PDE state: DOWN/HARDSTOP
sles10_sp3:~ # /etc/init.d/tpa start
Teradata Database Initiator service is starting...
Teradata Database Initiator service failed with 8 exit code

sles10_sp3:~ # /etc/init.d/tpa start
Teradata Database Initiator service is starting...
Teradata Database Initiator service started successfully.
sles10_sp3:~ # pdestate -a
PDE state is START/NETREADY.
sles10_sp3:~ # pdestate -a
PDE state is START/SYSGDOINIT.
sles10_sp3:~ # pdestate -a
PDE state is START/TVSASTART.
sles10_sp3:~ # watch pdestate -a
sles10_sp3:~ # tpareset -f "" -y

 

If at first you don't succeed; call it version 1.0

You must sign in to leave a comment.