All Forums Cloud Computing
padhia 35 posts Joined 06/10
12 Jan 2016
Teradata Express VMWare with Viewpoint

I don't know what I am doing wrong, but I am unable to register Teradata Express System as "monitored system" within viewpoint. I fill out all the required fields, the two required login connection test okay, but then when I click apply, there is a error icon next to the system which upoin hovering says "Cannot to connect to this Teradata database system to determine the system type". I tried and localhost as TDPID, but no luck even though tdwm and viewpoint (the second ID I created) test okay. 
Has anyone faced a similar situation?

padhia 35 posts Joined 06/10
15 Jan 2016

This might help someone in future. The second ID (viewpoint) that I added needed monitor privileges. It was somewhat catch22 - the GRANT button that would have generated the needed DCLs wasn't enabled until the system was added.

StevenSchmid 33 posts Joined 07/11
17 Jan 2016

Hi Padhia
When you see the message "Cannot connect to this Teradata database system", I believe the problem maybe that the "system config" collector has not run to be able to check the system version, unfortunately you can't change the sample rate.

Steven Schmid
Teradata DBA
Canberra, Australia

rrundo 1 post Joined 04/11
22 Jan 2016

Hi all,
I got the same problem today when I started my "Teradata Express VMWare with Viewpoint" image.
When I try to define the Teradata system in Viewpoint I see the message: "Only Teradata Express Edition systems may be configured which are running locally. The "Test" for the user "tdwm" fails.
 Note that the TD instance is working properly and the TD user "tdwm" and his password are ok. 

Fred 1096 posts Joined 08/04
22 Jan 2016

Did you create a viewpoint user and grant access as documented in the Viewpoint Configuration Guide?
Use dbc as the TDPID.

DaveWellman 66 posts Joined 01/06
06 Mar 2016

I'm having what looks to be the same problem (or at least very similar).
Trying to define the TD system to viewpoint, after filling out all the fields I click 'apply' and I get one of a couple of messages:
1) If I complete the field "tdpid" then I get "Only Teradata Express Edition systems may be configured which are running locally". I have tried 'dbc', 'localhost', '' all with the same results.
2) If I leave the "tdpid" field blank then I get a red error trianlge against it and a hover message saying "this fi3eld is required" (which is perfectly reasonable).
I have supplied the password for TDWM and added a viewpoint userid and for both of these (providing the "tdpid" field is filled in) the 'Test' button gives me a green tick.
I've checked the 'viewpoint.log file' and buried in the mess of java logging info is the following info:
2016-03-06 05:19:18,995 WARN  [http-nio-9080-exec-9] {context=/MrsAdminPortlet, user=admin} teradata.TeradataSystemFormController.processForm(258) - TD Express System Exception occured! Rejecting new system submission!
2016-03-06 05:19:29,193 ERROR [http-nio-9080-exec-6] {context=/MrsAdminPortlet, user=admin} teradata.TeradataSystemFormController.processForm(266) - Error occurred while trying to process system form!
java.lang.IllegalArgumentException: No enum constant com.teradata.viewpoint.system.TasmType.
Searching 'up' through the log file (i.e. messages previous to the above one) I found:
2016-03-06 05:19:18,980 ERROR [http-nio-9080-exec-9] {context=/MrsAdminPortlet, user=admin} jdbc.TeradataMonitorDAOJDBC.getPhysicalConfig(705) - Error retrieving Monitor Physical Config.
com.teradata.monitor.util.TeradataCliException: [Teradata Database] [TeraJDBC] [Error 3253] [SQLState 42000] Monitor Access Denied:  User has no Monitor Privileges.
So it looks like this process requires a logon to the TD system. I checked in dbc.logonoffv and found a 'failed logon' for user 'viewpoint' (this is the userid listed under 'tdwm' on the viewpoint page where I'm trying to add the system).
So I logged on to my TD system as DBC and granted MONITOR and 'EXECUTE FUNCTION' on SYSLIB to the viewpoint userid, but still no luck.
Anyone got any ideas as to how we can get VP configured?

Ward Analytics Ltd - information in motion

DaveWellman 66 posts Joined 01/06
06 Mar 2016

Ho hum... When in doubt logoff and logon again... (sound familair?)
Starting at the above stage, I logged off from VP and then logged on again.
I went into 'Viewpoint Administration / Monitored Systems'.
I clicked the '+' symbol and chose 'Add Teradata System'
I then worked down the page, one entry at a time:
System Nickname = TD1510
TDPid =
Site ID = I left this blank
I filled in the password for user 'tdwm' and clicked the 'Test' button. This worked and I checked it via dbc.logonoffv and can see the logon/logoff events there.
I entered the details for a second user (Name = viewpoint, password = viewpoint) and clicked 'Test' and all worked ok. Again, I checked via dbc.logonoffv that all was as expected.
I selected a time zone (in my case "GMT+0, Dublin, London, Azores")
I then clicked the 'Apply' button at the bottom... and it worked!
No, I don't really understand why but right now I'm not complaining.
I'm just setting up PDCR on my system (via DIP script) before I issue the 'grant' statements or the Viewpoint userid and then I'll do that.
I hope this helps someone else.

Ward Analytics Ltd - information in motion

jsummersgill 1 post Joined 01/16
13 Apr 2016

The viewpoint 13.10 configuration guide had the grants that enabled the configured IDs to work for me..
The 15.10 guide does not go into the same detail.
On page 9...
grant select on TDWM to viewpoint;
grant monitor to viewpoint;
grant select on DBC to viewpoint;

starry6690 1 post Joined 07/13
29 May 2016

padhia,you're right. I have met this problem. And I grant monitor privilege like you said, then click the "reset" button and add it again. it works. thank you

You must sign in to leave a comment.