All Forums Cloud Computing
TDobiee 9 posts Joined 07/09
27 Oct 2009
TDLOAD error on Teradata Express 13.0 for VMware

I am using the 40GB version of Teradata Express 13.0. It installed easily and the database is running fine. I am following the examples on the Developer Exchange - Introduction to Teradata Express for VMware Player and trying to load data from a file. I am having a problem with the new(?) tdload utility. I get an error when I try to run it:

Teradata Load Utility Version
Got CLI error 207 while connecting a session.
'MTDP: EM_NETCONN(207): Error in doing a network connect.'

Any ideas on what to do to fix this?


hyperj 7 posts Joined 09/09
27 Oct 2009

This error suggests a network issue such as a bad address or missing entry in the hosts file (/etc/hosts) in the linux vm. The dbccop1 entry ipaddress should match the ipaddress given by /sbin/ifconfig.

Does bteq work?

I will download, unzip and spin up the 13.0 vm as soon as I get a chance but in the mean time, here are a few of the solutions that applied when this problem has happened out in the field (long shots I think).

System has been rolled back to old dev system. Suggested that database retsart could have solved the problem.

Found that the host file on that node was missing the "cop" entry.

Network was configured as half duplex while the nodes were running at Full duplex

a reboot of the dev system cleared up the problem

TDobiee 9 posts Joined 07/09
28 Oct 2009

the dbccop1 address matches ifconfig. bteq works, but has an error:

Teradata BTEQ for LINUX.
Copyright 1984-2008, Teradata Corporation. ALL RIGHTS RESERVED.
Enter your logon or BTEQ command:
logon dbc/dbc;

logon dbc/dbc


*** Logon successfully completed.
*** Teradata Database Release is
*** Teradata Database Version is
*** Transaction Semantics are BTET.
*** Character Set Name is 'ASCII'.

*** Total elapsed time was one minute and 9 seconds.

BTEQ -- Enter your DBC/SQL request or BTEQ command:

hyperj 7 posts Joined 09/09
28 Oct 2009

Hmmm, I will get to trying to duplicate this today but in the mean time can you check for the presense of the tdgssconfig.gdo in /etc/opt/teradata/tdconfig? If it is missing, do this:

cd /opt/teradata/tdgss
bin/tdgssconfig etc/TdgssLibraryConfigFile.xml ../site/TdgssUserConfigFile.xml

hyperj 7 posts Joined 09/09
30 Oct 2009

I verified that the VM is configured correctly. I believe this issue ahs been resolved.

JimChapman 9 posts Joined 06/09
31 Oct 2009

FYI, one cause of connection errors is that (at least in the version that I downloaded on 10/28) the VM network card is configured to use DHCP. I recommend changing it to use a static IP address and then making sure that the host name dbccop1 is defined in /etc/hosts with the same IP address.

TDobiee 9 posts Joined 07/09
06 Nov 2009

I think that my download must have been corrupted. After downloading again, everything worked as advertized.

You must sign in to leave a comment.