All Forums Cloud Computing
ghammer 1 post Joined 01/13
11 Mar 2013
How do I access a VMWare hosted Teradata Express from a local TD Mapping Manager

 
I am running Teradata Express 14 running on a vmware hosted Suse Linux operating system.
Thus I have the following layers:
Windows 7 64bit
VMWare Player
Suse Linux
Teradata Express
 
My laptop has TD Mapping Manager installed on a Windows 7 32 bit system. I want the Mapping Manager repository to be placed in the virtualized Teradata Express database. Thus the Mapping Manager must be configured with an IP address that points to the virtual host on which Teradata is running. I have so far not been able to figure out how this can be done.
 
Any help will be highly appreciated.

DS186045 2 posts Joined 10/12
20 Mar 2013

Hello,
I too am having TD Mapping Manager/Teradata Client/Teradata 13.10 VM connectivity problems.  I was given the following steps:
1. If you are using TD 14.x, then you will need TTU 14.x. The new TTU tools such as TD Administrator can work with older versions of TD, but there are often problems trying to use an older version of the tool to access newer database versions. See appendix A of the TMM Getting Started guide for instructions on downloading and installing TTU (it mentions 13.10, you just need to download TTU 14.x instead). You should use Add/Remove Programs to remove all TTU 13.10 programs first. Most are named Teradata <toolname>. I think there is also an ODBC 13.10 that should be uninstalled.
 
If that doesn’t fix your problem, then:
2. Make sure VMware Player has the TD Express machine running, double-click on Gnome Terminal in VMware window to open it, type:
pdestate –a
in the Gnome Terminal window and press Enter.
You should get a status something like:
PDE state is RUN/STARTED.
DBS state is 5: Logons are enabled - The system is quiescent
3. Open TD Admin. You should get a dialog named “Please Select a Data Source”
Select the data source you created in step 3 (default is DEMOTDAT)
Maybe these steps may help....

Avid zClouder 14 posts Joined 04/13
02 May 2013

Thanks for the reply..It is really helpful..

z1reticuli 2 posts Joined 09/12
10 May 2013

Hi there. Can you go and expand a bit on this piece of info
"... 3. Open TD Admin. You should get a dialog named “Please Select a Data Source”
Select the data source you created in step 3 (default is DEMOTDAT) ... "
- There is nothing on creating anything in any step 3 in the text above

 

::m

tony.wilkinson 2 posts Joined 05/13
04 Jun 2013

Hi, I've recently joined Teradata and am trying to complete the TD Mapping Manager Course
I've installed TD Express 14:00 on a SUSE Linux VM on my Windows 7 Laptop and I'm trying to install TTU 14 as per instructions in the TMM course.  I can omly navigate to a place where I can install TTU 13.10.
I tried to read a posting from Edmond Ray on 31/12/2012 on this topic but when I clicked on the link I went to a page which said  EEP1 you've strayed to a part of the website you are not allowed into.
ANyway, any help on where I can get the download for TTU 14 for TD Express running on a SUSE Linux VM would be very much appreciated.

AndrewSchroter 14 posts Joined 11/06
05 Jul 2013

The ip address you use to access the Teradata Database on a VMPlayer Guest LINUX OS (Host was Win 7 in my case) can be obtained through executing the ifconfig command from the LINUX (guest OS where TD DBS runs from) command line (I used Gnome Terminal).  The output will look similar to below:
TDExpress14.0_Sles10:/ # ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0C:29:BE:A3:59
          inet addr:192.168.88.128  Bcast:192.168.88.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:febe:a359/64 Scope:Link
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:644 errors:0 dropped:0 overruns:0 frame:0
          TX packets:325 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:70783 (69.1 Kb)  TX bytes:32423 (31.6 Kb)                    ........
The line of interest from above starts with " inet addr: inet addr:192.168.88.128"

Enter whatever the ip address that is in the same place as "192.168.88.128" above appears (source value).  That value is to be pasted in the ODBC Administrator  Name(s) or IP address(es) Box (target location).

ManishM 5 posts Joined 01/08
03 Jan 2014

Hi,
I'm trying to get the IP of my VMWare Express -13.10
using the "ipconfig eth 0" cmd, but getting follwoing error :
 
s10-1310:~ # ipconfig eth0
bash: ipconfig: command not found
 
Plz. guide , if you have encountered/solved it.
 
Thanks.

Manish Mishra

ManishM 5 posts Joined 01/08
03 Jan 2014

Its resolved by using nslookup :)

Manish Mishra

NLSydney 1 post Joined 02/14
03 Feb 2014

Hi,
I am a new hire and trying to get mapping manager up and running as I'm doing the TD UNI course WBT45142. After getting VMware and getting the IP address, (192.168.91.128), Im trying to create a new repository as per the course intructions.
After entering the details(ip address etc.) I click on Create Repository and an error comes up:
The following SQL error was encountered while trying to connect to Teradata using information in Tools-> Preferences. You may need to change your preferences in order to avoid this error message on startup.
[TMM.SQL.0030]
 
Not sure how to resolve it, Thanks for looking and would appreciate your help.
 

ccurry 27 posts Joined 02/10
27 Feb 2014

I resolved this issue for the user when he contacted me using the "TMM, Support" email alias (Teradata employees only), but I did not know the issue was posted here too, as I do not monitor this forum. Non-Teradata-employees should use the Teradata Developer Exchange - Tools forum for support questions (employees can use the email alias above).
For this issue, you must use the IP address for the VMware virtual machine in the Create Repository Database dialog. See earlier in this thread (4 posts up, AndrewSchroter) for instructions to find that IP address.

Clark

amittera 35 posts Joined 12/09
20 Mar 2014

Hi ,
 
I wanted to install free version for Teradata 14 onto ome of the VM provided to me. Can somebody tell me if i need to install the SUSE linus free iso image and then the Teradata 14 database? If yes, can somebody give me the link where i can install the TD 14 database software. While searching, i came across varios files of Teradata express for VM WARE , assuming that it can directly get installed on a new physical machine ( which i can use as a test lab). I already downloaded the below :
 
TDExpress14.10_Sles10_1TB_VP_30cache (4.3 GB)
openSUSE-13.1-DVD-x86_64 (4.4 gb)
 
getting some what confused now. Please help

Amit Saxena
Teradata Consultant

VandeBergB 182 posts Joined 09/06
20 Mar 2014

Amit,
All you should need is VMWare, no install of linux is required.  Download and install a VMWare client, either server or player.  Unzip the TDExpress package and open up the virtual machine.
The TD Express package ia a linux based virtual machine, login with root/roor, double click on Teradata tools, double click on Start Teradata...you can check on the TD status by opening the gnome terminal and using pdestate -a  from the terminal command line.
while your terminal is open, use ifconfig eth0 to determine the  ip address of your new td install for connections from the operating system. 
cheers!

Some drink from the fountain of knowledge, others just gargle.

amittera 35 posts Joined 12/09
20 Mar 2014

Thanks ,
 
Although i am not good at Unix- Linux, but would try to take some body's help . I have been given two machines for which one i was trying to make as Teradata database server and the other to install ViewPoint. But i guess View Point also comes withing the package and i do not need any OS on either of the servers.
 
Do we have some screen shots step by step to follow. I saw it somewhere yesterday , but will still search.
Does this pkg works on WINDOWS also or a pkg inbuilt with Windows OS?

Amit Saxena
Teradata Consultant

amittera 35 posts Joined 12/09
20 Mar 2014

Also, if its installs with Linux , still i will be able to connect my toosl(sql assistant  etc) as GUI? right?

Amit Saxena
Teradata Consultant

sgarlapa 88 posts Joined 03/13
21 Mar 2014

Yes. By installing TTU 14.x. The new TTU tools such as TD Administrator, sql assistant on your windows 7 host machine, you can access the teradata server running on Linux (through vm player)
Need to create the DSN with the iP of the linux server
--Sri
 
 

amittera 35 posts Joined 12/09
25 Mar 2014

Vande,
 
Do we similar setup with Windows inbuilt , so i can run it on my second VM machine? Not sure if needs VM player there also...

Amit Saxena
Teradata Consultant

amittera 35 posts Joined 12/09
28 Mar 2014

Hi Team,

I downlaoded and copied the Teradata 14 SLES 10 VP 40 GB Version, but while selecting it gives me an error message : Your CPU does not support long mode, Use a 32 bit distribution. VM guys mention that the CPU is 64 bit, but not sure why its still giving, any clue?

Amit Saxena
Teradata Consultant

amittera 35 posts Joined 12/09
22 Apr 2014

Guys, 
 
If anybody is able to work out the TD 14 VM ware express installation, kindly let me know the machine configuration, as i am having hard time to get it installed .
Have checked TeraData Express sles10 VM compatibility and system requirements. I tried to run it on one of the hosts in our Lab. As per all the troubleshooting changed BIOS settings to enable VT option but I found that it is architecture of the processor differs i.e. VT-d and VT-x. Teradata VM errors shows VT-x error that means VT-x represents Intel's technology for virtualization on the x86 platform and all our lab servers are x64 platform.
 
Our Lab servers are having 64 bit  CPU and TeraData requirement is 64bit CPU which supports 32bit VT-x architecture as well. So in order to run TeraData package VM we need to have hardware (64bit CPU which supports 32bit architecture as well) 
From our lab end I did everything whatever required changes in the OS/Server level. I am not sure about the application side how they created VMs and settings. So as a remedy I need to have same set of hardware (i.e. CPU version, Model and hardware configuration) where this package is already running fine. 
 

Amit Saxena
Teradata Consultant

Tera_Lok 1 post Joined 06/14
28 Aug 2014

Hi Amit,
 
Could you please provide the link to download the VMWare Image of SUSE Linux, which have the Teradata Database installed. 
Kind regards
Lokesh

sgarlapa 88 posts Joined 03/13
11 Aug 2015
You can use below link Lokesh - 
http://downloads.teradata.com/download/database/teradata-express/vmware

 
 
 
 
 

You must sign in to leave a comment.