All Forums Cloud Computing
DaveWellman 66 posts Joined 01/06
16 Jan 2012
EC2 instance not running Sysinit / DIP ?

I'm trying to get a TD13.10 instance running and am having problems.

I've worked through the article about 'how to set up an EC2 instance',  'translating' from TD12 to 13.10 where necessary and get to the stage where I login to my instance and run the TD 'initialization' scripts.

I get asked to set the DBC password (which I set to 'DBC').

There are no disks to add but I think that's ok because I've added them (as "/dev/???") as EBS using ElasticFox.

When I click the 'go' button I get a few lines of output, very quickly but then nothing else happens. The Putty window is non-responsive. I have left it for @2 hours now and it is still not responding to key strokes or mouse button clicks.

The output in the putty window is:

|Configuring Teradata│
│EC2: │
│ │
│Instance-type: │
│m1.large │
│Availability Zone: │
│us-east-1c │
│System Type: SMP │
│Disk Devices: /dev/ │
│Total Capacity: 0 G │
│Sample Database: Y │
│ │
│ │
│This process may │
│take 20-60 minutes │
│ │
│ │

│Mon Jan 16 03:15:12 PST 2012 Starting Teradata│
│initialization ... │
│ │
│ * [X] Done generating configuration files. │
│ * [X] Done distributing configuration files │
│ to all the nodes. │
│ * => Starting to set the swap space ... │
│ * [X] Done setting the swap space. │
│ * => Starting to initialize the PDISKs ... │
│ * [X] Mon Jan 16 03:15:17 PST 2012 Done │
│ initializing the PDISKs. │
│ * => Mon Jan 16 03:15:17 PST 2012 Starting │
│ to run 'sysinit' ... │
│ * Done configuring SMP (PDE part). │

I've just noticed that in the 'summary' info on the left it says "capacity 0G" which probably means that I've got no disks attached / defined. Where did I go wrong ? Any ideas ?



Ward Analytics Ltd - information in motion www:
DaveWellman 66 posts Joined 01/06
18 Jan 2012

For anyone else who encounters this...

After getting some help from  Cliff Lindroth (Teradata) I scrapped my initial instance and started again. I think the key to what went wrong before was that I didn't get my disks associated with the instance correctly. Once that was done (through the Amazon AWS Management Console) then everything went through as per instructions.

A couple of pointers:

- if you are using IE as your browser then set it to compatability mode for the Amazon AWS Management Console.

- when attaching the disk volumes to the instance attach as "/dev/sdf" and  "/dev/sdg".

- when the "Teradata initialization process" is running (I ran mine through Putty) then   W  A  I  T... until the 'gui' screen disappear. It takes a good 15 minutes plus and part-way through it looks like all has finished. Wait until you get returned ot a plain Linux command line.

Cheers, Dave

Ward Analytics Ltd - information in motion

MrMadders 1 post Joined 08/14
24 Aug 2014

This was a massive help! Thanks Dave :-)
I have followed these steps now and got the instance up nd running and even run the query above on dbc which returned something.
What I'm not sure of though is if the Sample (Personnel?) database installed or not.
Do you have ny suggestions on how I might be able to check this?
Many thanks,

You must sign in to leave a comment.