All Forums Aster
amarnatha_86 1 post Joined 09/14
11 Sep 2014
R Configuration in Aster Express VM

 I downloaded the Aster Express 5.10 VM to evaluate R plugin i was able to activate the ncluster setup with one queen and
Worker node. however i am not able to complete install R into the clusters.
i followed the instructions given in the Aster_Express_User_Guide_0510 Pg 249 with opensuse repository [ languages:/R:/base/SLE_11_SP2/]
i get the following error

linux-buqz:/home/beehive/download # ls
R-base-3.1.0-76.1.x86_64.rpm R-base-devel-3.1.0-76.1.x86_64.rpm
linux-buqz:/home/beehive/download # ncli apm administer R --setuprepo=sles," languages:/R:/base/SLE_11_SP2/"
sles Repo created successfully.

linux-buqz:/home/beehive/download # ncli apm install R
Starting APM
Installing package sles-release
Error: Unable to load plugin R: zypper --root /opt/aster/third-party/R --no-gpg-checks --gpg-auto-import-keys install -y --no-force-resolution --auto-agree-with-licenses sles-release returned ret=104 stdout=Loading repository data...
Reading installed packages...
'sles-release' not found in package names. Trying capabilities.
stderr=No provider of 'sles-release' found.

However i am able to install R in the VM instance using the command "zypper install R-patched R-patched-devel"
P.S i am inside a proxy network does this affect the installation

Moyo 1 post Joined 09/15
26 Nov 2015

I have spent a week on this. I also followed the same instructions. I have tried installing with internet , I got the  "error: Unable to load plugin R: Command Zypper....Add a repository to the system".
I have tried installing Manually and I am getting the same error. I have tried this inside and outside a proxy.
 So did you finally manage to install R. How did you go around this error.


sarang181287 1 post Joined 02/14
26 May 2016

I am trying to install R on Aster VMware express 6.0, I have followed all the steps which are mentioned in USER Guide, but I am getting error while installing R from .iso file. My Error is 

aster-queen:/var/opt/teradata # ncli apm install R --usedefaultrrepo=False \

> --repo=sles,file:///var/opt/teradata/sles \

> --repo=sles-sdk,file:///var/opt/teradata/sles-sdk

sles Repo created successfully.

sles-sdk Repo created successfully.

Starting APM

Installing package sles-release

Successfully installed sles-release package

Installing package make

Successfully installed make package

Installing package gcc-fortran

R is not installed on the Aster Cluster. Please contact customer support.

Error: Unable to load plugin R: zypper --root /opt/aster/third-party/R --no-gpg-checks --gpg-auto-import-keys install -y --no-force-resolution --auto-agree-with-licenses gcc-fortran returned ret=4 stdout=Loading repository data...

Reading installed packages...

Resolving package dependencies...


Problem: nothing provides needed by gcc43-fortran-4.3.4_20091019-0.22.17.x86_64

 Solution 1: do not install gcc-fortran-4.3-62.198.x86_64

 Solution 2: break gcc43-fortran by ignoring some of its dependencies


Choose from above solutions by number or cancel [1/2/c] (c): c




Please let me know how to move further from this point :( 


Thanks in advance 


You must sign in to leave a comment.