All Forums Aster
toadrw 69 posts Joined 07/04
05 Jun 2014
Aster express root passwords

What are the root passwords for the Asterdata Express VM Queen and Worker Images.  I read that root/aster worked in the past, but it no longer does.  Thank you.

MartinJEd22 4 posts Joined 05/13
10 Jun 2014

Installed AsterLens on Queen Node Version 6, needed the root password for that. The combination root/aster worked fine. Which version do you use?

stavrosk 7 posts Joined 06/14
18 Jun 2014

I am expriencing the aforementioned problem with the Aster 6 VM images (straight downloads from I can login as aster/aster but the root/aster combo won't work and it gives me an "incorrect password" error msg.
When the VM came up I logged in with aster/aster and then I tried to su - but the aster password gives me the above error. I also tried logging in as root/aster but that wasn't successful either.
I researched for other combos but I didn't come across any other than root/aster.
I'd like also to mention that I had to convert the original images, as they came down from Teradata's web site, to copies that'll work on VMWare Player 4.0.6 Build - 1035888 (a free ver. of VM player) which i'm using to play them. I'd not expect that to have an impact on the root password but I'm reporting al the facts to be on the safe side.
Please let me know what I'm doing wrong or point me to the right direction.
I appreciate your feedback.

skojoze 1 post Joined 06/14
24 Jun 2014

i am having the same issues mentioned above with regards to the root credentials failing.  i'm a hosting engineer and have been tasked with standing up these vms in our production esx cluster for our solutions management group.  in order to do so, i had to use vmware converter to convert the vmware player image to an acceptable version of an VMware Infrastructure virtual aka vmx-09.  Now I have to correct the networking and need root to do so.  
recap:  aster/aster (works) & root/aster, root/root (doesn't work)
please help with supplying valid credentials?

chrislarsen 1 post Joined 06/14
26 Jun 2014

I have the same problem. Exact root password attempts as above and also tried root/<blank>, root/@ast3r, root/password, and others.
VMware player 6.0.2, Workstation 10.0.2, both have the same issue.
It would be very helpful to if nothing else, be able to shut down the vm gracefully.
Thanks in advance!

stavrosk 7 posts Joined 06/14
27 Jun 2014

Followed the steps of the process to reset a forgotten root password on a SUSE Enterprise Server as the following URL (and a lot of others a google search revealed) dictates.
and now I gained root access to the queen and worker images.
I hope that helps somehow.

andybaker 4 posts Joined 06/14
02 Jul 2014

I dont know how one is supposed to follow the process described - a power off, power on of the VMWare image on VMWare Player does not give me an option to boot from DVD (not that I have a Linux boot DVD anyway or a DVD drive on my laptop).  Maybe this is for folks with VMWare Workstation or I have missed something entirely. 
Wouldn't it be easier for the developer of the Aster 6 VMware image to simply post the root password and/or produce an image with a root password that matches the documentation?  By the way, the image I have doesn't have all of the datasets referred to in the tutorial  (eg is missing) whereas the Aster 5 VMWare image does have them (but I cant get them from there into the Aster 6 because of the lack of root access!)

stavrosk 7 posts Joined 06/14
03 Jul 2014

You need to dload and burn a SUSE Ent Linux v.11 SP2 DVD iso from SUSE's web site (they have an expiration date on them but that's not a problem since we'll be using to reset the root password), plug it into the physical DVD-ROM of the machine you are running the Aster VMs and Power Reset let's say the worker VM.
During the very first couple of seconds when the VM starts right at the very beginning when a black screen with the VMware logo and a progress bar at the bottom flashes you need to press F2. What works for me is right after I click Reset very quickly I mouse click into the initally black window of the VM and then I press F2 aggressively until the BIOS screen pops up. At that point you need to change the Boot order and bring the DVD at the top of the list so next time you Power Reset the VM it'll pick the DVD media. After that it should be easy to folow the URL's directions how to reset the root password. 
Before all of the above, make the sure that the physical DVD of your machine shows in the VM settings (Hardware Tab) and that the check boxes under Device Status are checked. Also, make sure that under Connection  - Use Physical Drive the VM auto detects the physical DVD (usually that's the default).
Originally I was playing the Aster VMs (both  with reset root passwords) on a free VMWare Player 4.x but the process completing cleaning up the worker never ended because of an "Error on socket 11: Connection refused" according to the cluster log. The Queen became Active w/o a problem.
So I used a VMWare Workstation 10.0.2-build 1744117 license we had available to set up an Aster cluster with 2 clean images downloaded from Teradata's site (w/o their root password reset). Everything went fine and the cluster became active w/o a problem. Next I will try to reset their root passwords to find out whether that will shake the cluster's stability.

23 Sep 2014

We are having the same problem root access to the Version 6 Aster VMs. We have tried stavrosk's approach and unfortunately without success. We get a read(dev/tty1): operation not permitted message. Any further advice would be apprecated.
It would be good if the root password was provided or new copies of the VM with Asterlens up and going. I would prefer to have the password.

23 Sep 2014

root password successfully changed using the advice in this article

praveenagg 1 post Joined 06/15
10 Jun 2015

just installed TDExpress15.00.01_Sles10_40GB_vp image. Installed successfully in VMware. able to type login as root. entering password. doesnt appear anything keyed in. getting login incorrect for 

Jens.Humrich 14 posts Joined 03/15
17 Jun 2015

A Combination of user aster/root and passwort aster/root always works for me :)
In the current system it is root/aster

You must sign in to leave a comment.