All Forums

For topics related to the Teradata Aster platform, including Aster Express for VMware Player.

You must login to post to the forums.
log file after shutdown Topic by knowledge 05 Sep 2016

i need to have a complete log for the system and users activities on ASTER.
i need it because after a shutdown in the weekend, i think for too many sessions or too many work space used, i can't find the real cause because the table of the statements don't save any more this data.

0 replies
Aster Management console (AMC) is not working for Aster Express Topic by singh_pawandeep 18 Mar 2014

Hi All,
I have downloaded the Aster express and followed all the instructions to configure the VMware and also started the queen and worker nodes but when I use the URL to open the AMC it does not open the console. I tried using IE9 and Google chrome both but none of them worked. Any suggestions/help will be really appreciated.

8 replies, 5 years ago
load_from_hcatalog --- error while selecting Varchar,Date,Timestamp column Topic by Arpan.Roy 09 Aug 2016 load_from_hcatalog, tdch, aster

Hi All,

We are trying to read data from Hive table and load into teradata table after lots of transformation. So, we are trying to use "load_from_hcatalog". But while selecting data, we are getting below error:


1 reply, 5 years ago
Visualizing an nTree Topic by lb185041 16 Dec 2013

Dear Aster gurus,
A very newbie question: how to visualize the rresult of an nTree function? I have a table with parent-child relationships, could build a nice graph (dependency list from the "bottom"), now I would like to see a graph, where these dependencies are visuallized. A Sankey or a Sigma chart would be OK.

1 reply, 5 years ago
Alternative to Strtok in Teradata Aster Topic by naresh01 01 Aug 2016 substring

Hi Team - i have a string field with about 600,000 rows like the below. Aster data base is connected through Teradata Studio.
I need each date in a different column, i tried strtok but Teradata studio gives me an error that it does not support strtok. Can anyone please help. thank you.

2 replies, 5 years ago
Code Assist not working Topic by Dan95 09 Aug 2016

I'm trying to use code assist for displaying a list of table after writting my database name. However code assist is not working, i'm on teradata studio express v15.11, any help ?
-> Code Assist is activated
-> Connection profile is ok

0 replies
First Teradata Aster Certification Exam Released Topic by TCPP-Admin 08 Aug 2016

The Teradata Certified Professional Program is excited to announce the release of  the first Teradata Aster Certification Exam – Teradata Aster Basics 6.10.  Passing this exam will earn you the Teradata Aster Certified Professional Credential.  Start preparing today and you’ll be one of the first to get Teradata Aster Cert

0 replies
Running ncluster_export fails with uppercase objects Topic by jan.simecka 29 Jul 2016 ncluster_export, uppercase, export

when running the ncluster_export for a database object containing uppercase letters, the object name gets translated to lowercase even if double quotes are used, resulting in a failure to find the object.

2 replies, 5 years ago
Download Visualization of App Center - Multi Character set Topic by AhnMiju 27 Jul 2016

In porject, I use the Table visualizer and like to download the data.
Our customer data is Han-gule and it is multi character set. If the data is english character then ok. But Han-gule data is broken.  
How can I solve this problem?

0 replies
Aster database/schema/table space management Topic by branko.p 21 Jul 2016

I'm having trouble allocating database space on aster when I create new db, schema or table. At what level can you allocate disk space (assuming at db level) and how can this be done? I'm using db super user credentials. Thanks.

2 replies, 5 years ago
Aster 6.0 to HDP 2.1 select does not work Topic by ulrich 16 Sep 2015 UDA Stick Aster HDP2.1 connection

I installed the UDA on a Stick package and run currently some of the examples.
TD15.0 and Aster 6.0 are runing and working fine.
HDP2.1 is also running. And hive is working on the HDP2.1 - I can run select * from freeze_frames from the hive consol and get results.
But when I run 
select * FROM load_from_hcatalog
(on mr_driver

5 replies, 5 years ago
Sort Sankey Diagram order- Topic by mhussey 18 Jul 2016

Hey everyone,

0 replies
Running AnyDatabase2Aster function error: java.lang.Null.Exception Topic by wz186002 03 Nov 2015

In Aster DB ,Use Teradata Studio use AnyDatabase2Aster function running a query statement, search oracle data. Following:
select * from AnyDatabase2Aster
(on (select 1) partition by 1

1 reply, 5 years ago
Aster Visualization Spacing Topic by mhussey 14 Jul 2016

I've started building some visualizations in Teradata App Center using Aster, and I'm running into an issue. The viz type I'm using in this example is a Sankey diagram. The visualization is generating correctly, but unfortunately, the data points are spreading WAY far apart, making a relatively small amount of data impossible to see all at once. I've attached a picture showing the issue.

4 replies, 5 years ago
Find Create Timestamp of a table Topic by chenstef 12 Jul 2016

Is there a way to find the Create timestamp and Last Modified timestamp of a table?

0 replies
Automating grants in Aster Topic by mjlocat 05 Jul 2016

We have implemented both data roles and user roles in Aster. I wanted to create some way to make it easy for users to apply the proper grants to their tables when they're ready to allow others access to the tables. Generally, I'd write a procedure that takes in the schema name and table name and would dynamically create and execute something like:

1 reply, 5 years ago
Loading JSON to ASTER Topic by sg186097 05 Jul 2016 JSON on ASTER, Loading JSON to ASTER Database

I have Aster express on my desktop and would like to upload JSON objects from a file to a Table on ASTER. Datatype JSON is not supported, and I tried using VARCHAR, but it did not work. JSON got corrupted when I did so..
What is the best way to load a JSON object to ASTER Table from a file...(for example: from twitter dump file)
Thanks in advance

1 reply, 5 years ago
INSERT undocumented syntax Topic by zszmigiero 24 Jun 2016

I have noticed that INSERT with bracketed query is supported what is not documented in Aster SQL reference:
- INSERT INTO table (query)
Should I treat this as a bug or another syntax not included in the documentation set?

2 replies, 5 years ago
using Teradata Stored Procedures to pull data into Aster Topic by mm185159 27 Jun 2016 Stored Procedure;QueryGrid, load_from_teradata;

I am unable to get a stored procedure call that returns a dynamic data set to execute from Aster via the TDConnector. Is this becasue the QueryGrid function load_from_teradata only supposts a SQL Select statement, period? If so, is there any other method or function that can call a TD SP to return data to aster and load into an Aster table?

3 replies, 5 years ago
How to list all seqeunces? Topic by zszmigiero 22 Jun 2016

There is not system view to list all sequences.
I found some information inside nc_all_columns but Aster provides GRANT on sequence without simple way to identify their names.

2 replies, 5 years ago
Load with Informatica PowerCenter into Aster Topic by DietmarEsser 24 Jun 2016 informatica, powercenter, ncluster_loader, pipe, aster

Dear community,
for one of my customers I am looking for best practices and guidelines for loading data with Informatica PowerCenter into Aster.
Any feedback or guidance on this would highly be appreciated.

0 replies
ERROR: SQL-MR function TEXT_PARSER failed: Loading stop word file /stopwords_en.txt failed. Topic by shiboo18 21 Jun 2016 TEXT_PARSER

Hi guys,
I am new to Aster. Only like 3 weeks into it.
I am using TEXT_Parser analytic function. I want to use my own stop word file.
I have loaded the file from my local into AFS using this command:
 \afs -copyFromLocal ./Test/stopwords_en.txt adfs:///

1 reply, 5 years ago
Loading XML files in Aster Topic by gtu4teradata 16 Nov 2015 xml, XMLParser, XMLRelation

I need to load an xml file in Aster Database
I need to use functions like XMLParser OR XMLRelation.
But both the above functions need a table as input. So how do I get this xml file into a table

1 reply, 5 years ago
How to get info from system tables using pyodbc? Topic by zszmigiero 17 Jun 2016

I tried to get data from nc_all_users using pyodbc where only cursors are available for tetch data. Unfortunatelly AsterDB returned error:
('HY000', '[HY000] [AsterData][nCluster] (34) ERROR: declare cursor statement may not reference system tables.  (34) (SQLFetch)')
Any idea how to get data from system tables using Python?

2 replies, 5 years ago
Failed to start cluster activation Topic by MartinJEd22 30 Apr 2014 aster, nCluster failed

I've followed the "getting started" instructions for Aster Express. I'm using 5.0express-r29890.
Successfully added the Worker node but when I click on "Activate Cluster" I always get "Failed to start cluster activation" in the status bar. I saw during start-up of the worker node that the nCluster service failed to start. 

5 replies, 5 years ago