All Forums Analytics
quinnj 1 post Joined 01/12
06 Jan 2012
Error Connecting to JDBC Database in teradataR

Hi All, first time posting on here, so let me know if this question has already been asked or belongs somewhere else.


After installing the teradataR package in R along with the RJDBC package, I try to follow instructions from the teradataR package manual ( teradata-r/teradataR_1.0.1_UserGuide.pdf), but continue to receive the same error each time.

I'm trying to connect to my company's JDBC teradata database; my code is as follows:

> tdConnect("[database server name]", [username], [password], "[database name], "jdbc")


But each time I try to run it I get the same error as follows:

"Error in .jfindClass(as.character(driverClass)[1]) : class not found"

Any ideas as to what is going wrong?  Could it be a backend permission/access problem with my database?  

Any help would be greatly appreciated!



dburkhard 1 post Joined 12/11
19 Jan 2012


Are you sure you have the teradata jdbc jars loaded?  If the jdbc jars don't show up when issuing:


you might want to load them - e.g:


.jaddClassPath( "<path>/terajdbc4.jar" )

.jaddClassPath( "<path>/tdgssconfig.jar" )

In addition, I had to also initialize JDBC:

drv <- JDBC("com.teradata.jdbc.TeraDriver", "", "`")



You must sign in to leave a comment.