All Forums Viewpoint
ab186024 16 posts Joined 11/11
04 Feb 2016
ERROR: Unable to start viewpoint

Hi All,
I'm unable to start viewpoint in TD Express 15.10
All services are running fine but can't start viewpoint:

TD-EXPRESS:/opt/teradata/viewpoint/bin # vp-control.sh start

Thu Feb 4 20:42:26 EST 2016  Starting all Teradata Viewpoint services.

Thu Feb 4 20:42:26 EST 2016  tdactivemq: starting...

Starting Teradata ActiveMQ                                                                                                                      done

Thu Feb 4 20:42:26 EST 2016  tdactivemq: started

Thu Feb 4 20:42:26 EST 2016  camalert: starting...

Starting Teradata Alert Service                                                                                                                 done

Thu Feb 4 20:42:26 EST 2016  camalert: started

Thu Feb 4 20:42:26 EST 2016  tmsmonitor: starting...

Starting TMSMonitor                                                                                                                             done

Thu Feb 4 20:42:26 EST 2016  tmsmonitor: started

Thu Feb 4 20:42:26 EST 2016  dcs: starting...

Starting DCS                                                                                                                                    done

Thu Feb 4 20:42:26 EST 2016  dcs: started

Thu Feb 4 20:42:26 EST 2016  viewpoint: starting...

Starting Viewpoint                                                                                                                              failed

Thu Feb 4 20:42:37 EST 2016  ERROR: Unable to start viewpoint.

 

Firefox:

Firefox can't establish a connection to the server at 127.0.0.1

Firefox can't establish a connection to the server at 127.0.0.1/c

Firefox can't establish a connection to the server at 127.0.0.1:80

Firefox can't establish a connection to the server at 127.0.0.1:9080

 

Anyone having the same issue or know to fixe this. Thank you

 

 
 

ABH
Fred 1096 posts Joined 08/04
15 Feb 2016

If the Viewpoint portal isn't starting, then of course Firefox won't connect.
 
Take a look at the end of /opt/teradata/viewpoint/portal/logs/viewpoint.log to see if more detailed error information is available.

Swati Kamat 1 post Joined 01/16
12 Apr 2016

Hi Fred,
I am also facing the same problem and I see below error in the log.
 
ERROR 10 Apr 2012 22:38:26,368 [main] [org.apache.activemq.broker.BrokerService.<clinit>(160)] Failed to resolve localhost

ERROR 10 Apr 2012 22:38:31,033 [main] [net.sf.ehcache.Cache.<clinit>(128)] Unable to set localhost. This prevents creation of a GUID. Cause was: TDExpress140_Sles10: TDExpress140_Sles10
java.net.UnknownHostException: TDExpress140_Sles10: TDExpress140_Sles10
 
I am able to connect to the database via SQL Assistant and bteq.
 
But I don't have a clue why it is throwing unknown host exception.
 
Could you please help on this. Thanks in advance.

Thanks & Regards,
Swati Kamat

cr255014 23 posts Joined 01/14
12 Apr 2016

You can edit your hosts (/etc/hosts) file and add hostname beside to localhost. To get hostname of local vm, run hostname command, and then try restarting services.
 
From the error, your hostname looks to be "TDExpress140_Sles10"

Fred 1096 posts Joined 08/04
13 Apr 2016

Is your system clock really set to April 2012? Or is that just an old log message that was left when the VM image was built.
 

You must sign in to leave a comment.