All Forums Teradata Studio
slemmer 4 posts Joined 03/15
07 May 2015
Teradata 15.1 Error when trying to execute query

Had Teradata Studio 15.0 loaded on Windows 7.0.  Then upgraded to Studio 15.1.  I now get the error below when trying to execute a query.
 
java.lang.ClassCastException: org.eclipse.datatools.sqltools.db.generic.service.Gene ricSQLService cannot be cast to com.teradata.datatools.dtp.sqltools.db.teradata.servic es.ITeradataSQLService
 at com.teradata.datatools.dtp.sqltools.db.teradata.Terada taExecuteMultiSQLAction.run(TeradataExecuteMultiSQLAct ion.java:160)
 at com.teradata.datatools.dtp.sqltools.db.teradata.Terada taExecuteMultiSQLAction.run(TeradataExecuteMultiSQLAct ion.java:118)
 at com.teradata.datatools.dtp.sqltools.ui.editor.Teradata SQLEditor.handleExecuteIndividual(TeradataSQLEditor.ja va:915)
 at com.teradata.datatools.dtp.sqltools.ui.editor.Teradata SQLEditor.handleRunMenuButtonSelected(TeradataSQLEdito r.java:783)
 at com.teradata.datatools.dtp.sqltools.ui.editor.Teradata SQLEditor.access$14(TeradataSQLEditor.java:777)
 at com.teradata.datatools.dtp.sqltools.ui.editor.Teradata SQLEditor$12.widgetSelected(TeradataSQLEditor.java: 942)
 at org.eclipse.swt.widgets.TypedListener.handleEvent(Type dListener.java:248)
 at org.eclipse.swt.widgets.EventTable.sendEvent(EventTabl e.java:84)
 at org.eclipse.swt.widgets.Display.sendEvent(Display.java :4353)
 at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java: 1061)
 at org.eclipse.swt.widgets.Display.runDeferredEvents(Disp lay.java:4172)
 at org.eclipse.swt.widgets.Display.readAndDispatch(Displa y.java:3761)
 at org.eclipse.e4.ui.internal.workbench.swt.PartRendering Engine$9.run(PartRenderingEngine.java:1151)
 at org.eclipse.core.databinding.observable.Realm.runWithD efault(Realm.java:332)
 at org.eclipse.e4.ui.internal.workbench.swt.PartRendering Engine.run(PartRenderingEngine.java:1032)
 at org.eclipse.e4.ui.internal.workbench.E4Workbench.creat eAndRunUI(E4Workbench.java:148)
 at org.eclipse.ui.internal.Workbench$5.run(Workbench.java :636)
 at org.eclipse.core.databinding.observable.Realm.runWithD efault(Realm.java:332)
 at org.eclipse.ui.internal.Workbench.createAndRunWorkbenc h(Workbench.java:579)
 at org.eclipse.ui.PlatformUI.createAndRunWorkbench(Platfo rmUI.java:150)
 at com.teradata.studio.StudioApplication.start(StudioAppl ication.java:33)
 at org.eclipse.equinox.internal.app.EclipseAppHandle.run( EclipseAppHandle.java:196)
 at org.eclipse.core.runtime.internal.adaptor.EclipseAppLa uncher.runApplication(EclipseAppLauncher.java:134)
 at org.eclipse.core.runtime.internal.adaptor.EclipseAppLa uncher.start(EclipseAppLauncher.java:104)
 at org.eclipse.core.runtime.adaptor.EclipseStarter.run(Ec lipseStarter.java:380)
 at org.eclipse.core.runtime.adaptor.EclipseStarter.run(Ec lipseStarter.java:235)
 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
 at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
 at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknow n Source)
 at java.lang.reflect.Method.invoke(Unknown Source)
 at org.eclipse.equinox.launcher.Main.invokeFramework(Main .java:648)
 at org.eclipse.equinox.launcher.Main.basicRun(Main.java: 603)
 at org.eclipse.equinox.launcher.Main.run(Main.java:1465)

fgrimmer 553 posts Joined 04/09
07 May 2015

Stephanie, What type of connection profile is associated with your SQL Editor window? Do you get the same error when you perform the execute by doing a right click>xecute As Individual Statements?

AxelJacquin 2 posts Joined 04/15
20 May 2015

Hello,

I have the same error. (But it works on Teradata Studio Express)
My connection profile in my SQL Editor window is New Aster Database.
 
Any ideas ?
 

fgrimmer 553 posts Joined 04/09
20 May 2015

Axel, What version of Studio are you running?

lsroxas 1 post Joined 05/14
26 May 2015

I just downloaded Studio Express 15.1 and I am experiencing the same error when trying to run a query on a Teradata Database. Test connection is ok. I am also able to see the database structure in the Data Source Explorer window but I am unable to query anything. Can anyone help?

fgrimmer 553 posts Joined 04/09
26 May 2015

Lubert, Just to recap running queries: Select the connection profile in the Data Source Explorer (DSE) and double click to create a connection. Then choose the DSE toolbar button Open SQL Editor to open a SQL Editor that is connected to your connection profile. You can verify that your Connection Profile is connected by the connection icon turing green. Enter your SQL statement. Then right click and choose Execute All or Execute as Individual Statements, or Execute Current Text.Or you can use F5 or  Ctrl+Alt+X. What happens when you try one of these? 

gtmmaj 4 posts Joined 09/15
21 Jul 2016

Isroxas, how did you fix this issue? Could you please share.
 

gtmmaj 4 posts Joined 09/15
21 Jul 2016

I am getting the following error message:
Failed to execute SQL:

org.eclipse.datatools.sqltools.db.service.GenericSQLService cannot be cast to com.teradata.datatools.dtp.sqltools.db.teradata.service.ITeradataSQLService

fgrimmer 553 posts Joined 04/09
24 Jul 2016

@gtmmaj, What version of Studio are you using? This issue should be resolved in our latest 15.11 release.

bkasterm 3 posts Joined 10/15
02 Aug 2016

I get the same error as @gtmmaj, my teradata studio is version 15.11.0.201605311155 downloaded an hour ago.

bkasterm 3 posts Joined 10/15
02 Aug 2016

BTW: I am on OS X 10.10.5 (Yosemite).

fgrimmer 553 posts Joined 04/09
02 Aug 2016

Can you open an incident for this so we can gather the error logs and configuration information? As a work around, can you try creating another connection profile with the same attributes as the first one (that fails) but give it a different name and select it in the drop down selection in the SQL Editor? Let me know if this helps.

siddharth91 1 post Joined 08/16
02 Aug 2016

Getting the same error. Version : 15.11.0.201605311154 downloaded 30 mins ago...  My Mac Version is : 10.11.5 (El Capitan)

bkasterm 3 posts Joined 10/15
08 Aug 2016

Teradata studio express has worked fine for me; so that is my current solution, just use the express version.

gtmmaj 4 posts Joined 09/15
18 Aug 2016

It is now working fine for me. Thanks @fgrimmer. I am now using TD 15.11

monsieurvinodh 1 post Joined 11/14
19 Aug 2016

Downloaded Just 20 mins back.. It is on Windows 7 64 bit machine.. Version --> TeradataStudioExpress__win64_x86.15.11.00.00
Below Error Message:  [[ Only when submitting queries ]]
failed to execute SQL: org.eclipse.dataools.sqltoos.db.generic.service.GenericSQLService cannot be cast to com.teradata.datatools.dtp.sqltools.db.teradata.services.ITeradataSQLService
Strange facts:
--able to ping
- able to see all database objects
But threw above error only when I submit queries.. Please throw some light on this.. 
 
- Vinoth

Vinoth

fgrimmer 553 posts Joined 04/09
22 Aug 2016

Vinoth, I think there is a problem in selecting the conneciton profile in the SQL Editor. A workaround is mentioned above. As a work around, can you try creating another connection profile with the same attributes as the first one (that is failing) but give it a different name. Select the new connection profile in the drop down selection in the SQL Editor.  Let me know if that helps. We should have this fixed in upcoming 15.12 release.

fgrimmer 553 posts Joined 04/09
08 Sep 2016

Vinoth, Studio 15.12 will be available after the Teradata Partners conference next week. Sorry for the delay.

You must sign in to leave a comment.