All Forums Teradata Studio
SNguyenWF 18 posts Joined 06/16
22 Jun 2016
Studio Express severe keyboard lag

I am experiencing severe keyboard lag with Studio Express ever since I installed it couple months ago.  It started with the previous version (15.10.1.1) and still exists with 15.11.
My laptop: Windows 7, Intel Core i5 @ 1.90Ghz, 8 GB RAM, 64-bit.
The issue I have is keyboard lag.  It's as simple as that.  When I open a blank SQL editor window or an existing SQL file, everything works fine -- Typing response and usage of arrow keys are all good.  But, soon afterwards, say after typing some code and running some of them, 20 to 30 minutes of continuous usage (it can vary), the keyboard starts to lag severely.  If I close the file and re-open, things are fine again, but of course, only temporarily.
I've viewed few different threads on this forum related to this topic.  Though they seemed to focus mainly with Mac users, I tried the different suggestions for my Windows computer anyway.  I've tried modifying the Java settings in the TeradataStudioExpress.ini file (the xms and xmx parameters), but that didn't work.  I've tried changing the cache size in Java Control Panel, but that didn't work.  I looked into toggling off the code assist feature, but I never had that on in the first place.  I also tried turning off syntax validation, typing aids, and maybe another thing or two in preferences, but none of them worked as well.
Just wondering if there any new thoughts or ideas to troubleshoot this.  I was really hoping that the 15.11 release would fix things, but it didn't.  Whether I installed it on top of the older version or uninstall the old and then reinstall the new, the same issue persists.

fgrimmer 553 posts Joined 04/09
22 Jun 2016

Steven, Have you looked into your graphics card. I found one thread that mentioned this same issue and when they switched the driver version for their NVIDIA card, it resolved the issue. Just wondering if there is any issues there?

SNguyenWF 18 posts Joined 06/16
23 Jun 2016

Hmm, I don't think I have a problem there.  I have the latest version of the driver for my integrated Intel graphics.

fgrimmer 553 posts Joined 04/09
01 Jul 2016

Steven, We will continue to look into this issue.

SNguyenWF 18 posts Joined 06/16
06 Jul 2016

I was looking in the teradata.log file found in the workspace directory.  An entry I'm curious about and which happens frequently is:
"2016-06-28 10:51:54,089 Teradata Datatools [main] ERROR com.teradata.datatools.dtp.sqltools - Unexpected database version 0.x, using latest version's parser"
What does this mean, and could it be related to my issue?

fgrimmer 553 posts Joined 04/09
07 Jul 2016

It means that the version of the database is not recognized by Studio Express. What version of Teradata are you connecting to?

SNguyenWF 18 posts Joined 06/16
07 Jul 2016

I've been connecting to Teradata v. 15.10.1.08.

SNguyenWF 18 posts Joined 06/16
07 Jul 2016

I noticed the following.  Curious as to whether any of these values look right and could be causing the keyboard lag, considering that I'm running on a 64-bit Windows computer.  I obviously don't know what these parameters mean, except for the workspace specification ("-data").

BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US

Command-line arguments:  -os win32 -ws win32 -arch x86_64 -data C:\ProgramData\Teradata\Workspace

 

fgrimmer 553 posts Joined 04/09
07 Jul 2016

As you mention, the -data is to re-locate the workspace. Are you launching with -data? Where is your workspace created? By default, Studio Express will create the workspace in your %HOMEDRIVE%%HOMEPATH%, as per the desktop shortcut. Are you using the desktop shortcut to launch Studio Express? 
When you notice the SQL Editor lag, are you highlighting words in the SQL Editor when it happens?

SNguyenWF 18 posts Joined 06/16
07 Jul 2016

Yes, I'm launching using the desktop shortcut and with -data.  The desktop shortcut launches with the re-located workspace.  It has a "start in" of %HOMEDRIVE%%HOMEPATH%.  The workspace location must have been imposed by my company, but I don't think there's any reason why I can't change it to the program defaults.  I'm not sure about the pros/cons of the two options.  Does it make a difference, since the default and custom workspace locations are both on the hard drive.
 
The SQL Editor lag doesn't really occur when highlighting text.  It happens when typing or moving the cursor with arrow keys.

fgrimmer 553 posts Joined 04/09
07 Jul 2016

Not sure why it would matter having the workspace created in ProgramData? We have seen some customers that have the <USER> driver on a LAN drive and this causes issues when the network is unavailable or slow. Can you try creating your workspace in another location on your hard disk and see if that helps the performance issue? thanks.

SNguyenWF 18 posts Joined 06/16
11 Jul 2016

I removed the -data parameter from program launch (thus, using the default workspace location) and still having the same lag issue.  I might just have to resort to using SQL Assistant if the issue drives me more insane.

SNguyenWF 18 posts Joined 06/16
15 Jul 2016

I have a new observation with this issue.  I notice that when I have a big block of commented code, when I type or use the arrow keys within it, there's no lag, but when I go to another section of code (not commented), I get the lag.

SNguyenWF 18 posts Joined 06/16
04 Aug 2016

I also installed 32-bit version of Studio Express, but I still get the same issue.  I also uninstalled and then re-installed Java -- Issue still persists.  Same as before: Once I've been doing stuff in the editor after a while, keyboard starts to lag.  Closing the window then re-opening the SQL file gets things back to normal.

fgrimmer 553 posts Joined 04/09
04 Aug 2016

Steven I have found a bug with the double click handler for the SQL Editor. Do you still see the problem if you don't double click on words in the editor?

SNguyenWF 18 posts Joined 06/16
05 Aug 2016

Very interesting.  I double click words all the time!  That could be the issue.  I'll try to avoid doing that and see if the issue goes away.

fgrimmer 553 posts Joined 04/09
05 Aug 2016

OK, Let me know. We have fixed this issue in our upcoming 15.12 release (scheduled for mid September.

SNguyenWF 18 posts Joined 06/16
25 Aug 2016

I was on vacation for a while, but I have been avoiding double clicking on words over the course of a week or so and am convinced that that was the issue.  I'm glad that the issue is fixed for 15.12.  Looking forward to the new version! :)

fgrimmer 553 posts Joined 04/09
08 Sep 2016

Steven, Studio 15.12 will be available after the Teradata Partners conference next week. Sorry for the delay.

You must sign in to leave a comment.